'error occurred while processing: "bindings"...' when inspecting Function.prototype

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
4 months ago

People

(Reporter: bbenvie, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Steps to reproduce:

1.) Open browser console
2.) Execute "Function.prototype" and then click to open it in the VariablesView

This produces the following error:

error occurred while processing 'bindings: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMWindow.sessionStorage]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource://gre/modules/devtools/dbg-server.jsm -> resource://gre/modules/devtools/server/main.js -> resource://gre/modules/devtools/server/actors/script.js :: EA_bindings :: line 3403"  data: no]
In a debug build I hit the assertion in bug 912536. Do you have an opt build?
(Reporter)

Comment 2

5 years ago
Yeah this is opt build.
OK, let's retest after bug 912536 lands.
Depends on: 912536
Retest?
Yep, seems to be working now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.