Users not shown the payment terms of service

VERIFIED FIXED in 2013-12-03

Status

Marketplace
Payments/Refunds
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Andy McKay, Assigned: Andy McKay)

Tracking

2013-12-03
x86
Mac OS X
Points:
---

Details

Attachments

(1 attachment)

32.50 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
(Assignee)

Description

5 years ago
When we were at Bango we were shown a terms of service. This was a long Word document that I think Steve had.

I showed the SBI agreement that we show to users and its quite small. This is quite a different document that looks like a big pile of legalise. Should this be shown to developer signing up with their payment account? Does someone have a copy of this document?

If so, do we have a preference in the payment flow?
(Assignee)

Updated

5 years ago
Priority: -- → P2
I am only aware of the short document which was given to us by Bango.  I will follow up with Bango to clarify the difference and see if we need to be concerned.
(Assignee)

Comment 2

5 years ago
Thanks. At this point there is no document that I know describing when a developer is too be paid out and the threshold of payout etc. That's only referenced in this terms of service.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 930554
(Assignee)

Comment 4

5 years ago
You sent me a couple by email, are those the final ones? Are there requirements about when they should be shown, can it just be a link, once per account creation, or once per user?
Flags: needinfo?(dbialer)
No not the final.  We have a request for that to ensure we get the right one.

I believe it is an affirmative acceptance as the requirements.  Once per year per developer with the initial acceptance on account creation.

I will attach the dev agrement when I receive it.
Flags: needinfo?(dbialer)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 938909
(Assignee)

Updated

5 years ago
Flags: needinfo?(udevi)
Mika - 
WHen ya get a sec - Please attach the updated / final Developer Agreement from Bango

:-)
(Assignee)

Comment 8

5 years ago
I spoke about this with Bango yesterday and their understanding was that we will host the terms and do the localisation.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 929661
(Assignee)

Comment 10

5 years ago
This is to be shown here:

https://github.com/mozilla/zamboni/tree/master/media/docs/pay-providers

Replacing the existing bango-en.v1.pdf.

Next, when a developer signs up they should:

- enter their bank account details
- then see this terms of agreement
- then see the SBI from Bango
- then agree
Assignee: dbialer → amckay
Flags: needinfo?(udevi)
Target Milestone: --- → 2013-12-03
(Assignee)

Comment 11

5 years ago
Created attachment 8336467 [details]
Bango's Developer Terms - 20131105.docx

Update terms. Will need converting into HTML and PDF.
(Assignee)

Comment 12

5 years ago
https://github.com/mozilla/solitude/pull/175
https://github.com/mozilla/zamboni/pull/1448
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 13

5 years ago
Please add STR here or mark it with [qa-] if no QA is needed.
Flags: needinfo?(amckay)
(Assignee)

Comment 14

5 years ago
STR: go to sign up for a bango payment account on stage, note the new much longer terms of service, as per the screenshots in https://github.com/mozilla/zamboni/pull/1448.
Flags: needinfo?(amckay)

Comment 15

5 years ago
Verified as fixed in https://marketplace-dev.allizom.org/developers/ on FF28 (Win 7).
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.