Mouse movement can interrupt touch scrolling with APZC enabled

RESOLVED DUPLICATE of bug 917385

Status

Firefox for Metro
Pan and Zoom
RESOLVED DUPLICATE of bug 917385
5 years ago
4 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

Trunk
All
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 812901 [details] [diff] [review]
patch

Bug 896017 added code to prevent us from switching input modes in the middle of a touch gesture.  This is no longer working correctly with APZC enabled though, because APZC cancels the touch and stops dispatching touch events during a pan.  Instead we need to listen for notifications from APZC.

Note: Even with this patch, I get some odd behavior if I move the mouse while panning, but it happens after the pan instead of interrupting it.  I'll file a follow-up bug on that once I've investigated it a bit more.
Attachment #812901 - Flags: review?(jmathies)

Comment 1

5 years ago
I think the right fix to this is just to do it down in widget/windows/winrt code (bug 917385). It'll be easy there to detect which input we are receiving and fire an observer as a result. With apz it's almost impossible to keep the front end state accurate.
(Assignee)

Updated

5 years ago
Depends on: 917385

Updated

5 years ago
Attachment #812901 - Flags: review?(jmathies) → review-

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 917385
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.