[inari][music] Long mp3s "skip" like a record when first starting

RESOLVED FIXED

Status

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: squib, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(This is probably a platform or hardware issue, but I'm going to put this in Gaia::Music for the time being while I figure out what the actual issue is.)

I noticed this on my flight to the Oslo work week (hooray for dogfooding!): long mp3s skip like a record when they're first loaded, playing the first second or two a few times until it finally rights itself and plays normally. It seems to only happen with mp3s that are at least 13-ish minutes long, although it's more pronounced when the music app is in the background or the screen is off, presumably because the process priority is lower then.

This seems to happen with all kinds of mp3s. I've specifically tested 320kbps CBR and v0 VBR, and both of them exhibit the same issue. It doesn't seem to happen at all for Ogg Vorbis files however, leading me to suspect that this is an issue with the drivers for the hardware mp3 decoder.

It may help people testing this to apply my patch in bug 902981, which allows you to control the music app when it's in the background. This way, you can cycle to the next song while the music app is in the background and thus has a lower process priority, making it easier to reproduce this. Alternately, you can just seek to a few seconds before the end of the previous song, turn off the screen, and wait for the song in question to start up.

If you're looking for some mp3s to test this on, there's a demo album freely available here: <http://wolvserpent.com/wolvserpent/>. Just click on the "Download Wolvserpent “Perigaea” 2012 demo HERE" text about halfway down. The issue is most readily apparent on track 2, since the music starts immediately. For anyone testing with this album, here's hoping you don't mind doom metal. :)

If you'd like other test files, I'm sure I can find some, but for obvious copyright reasons, I can't post them publicly.
Bug 914870 and Bug 922334 might be related.
Bug 783512 might also be related.
blocking-b2g: --- → koi?
blocking-b2g: koi? → ---
This works for me now. However, there are some other issues that have appeared as fallout to the fix for this, which I'm currently investigating.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
(In reply to Jim Porter (:squib) from comment #4)
> This works for me now. However, there are some other issues that have
> appeared as fallout to the fix for this, which I'm currently investigating.

Please file new bugs for those and CC me please.
Blocks: 927884
You need to log in before you can comment on or make changes to this bug.