Saving a video from web will not retain the meaningful filename, instead says "Videoplayback"

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Browser
RESOLVED WONTFIX
5 years ago
4 months ago

People

(Reporter: johnhu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

This is the following up bug for bug 915911. When saving the video file from YouTube, the filename is {timestamp-}videoplayback.mp4. The filename of video should be meaningful.
See Also: → bug 915911
(In reply to John Hu [:johnhu] from comment #0)
> This is the following up bug for bug 915911. When saving the video file from
> YouTube, the filename is {timestamp-}videoplayback.mp4. The filename of
> video should be meaningful.

I'd add that the videos should also be stored in a meaningful directory like downloads/videos/ rather than just being dumped on the root of the sdcard.

And "meaningful" doesn't have to be "the actual title of the video". Using the filename from the webserver seems like the best guess for a meaningful name. But if the vast majority of saved videos will be from youtube and youtube always gives us "videoplayback", then that is no longer meaningful.  Just the timestamp by itself would be better than "videoplayback", especially if the file were in a downloads/videos/ directory because then it would be clear that it was a downloaded video and the timestamp would specify when downloaded.

Maybe the way to fix this is to just explicitly filter out youtube's videoplayback string.  That is, assume that the filename is meaningful, unless it is known to be a on list of useless filenames. That list could start off just including Youtube's useless name.

I'd also argue that the filename should always include the timestamp and not only use it to resolve name conflicts.
Duplicate of this bug: 922959

Comment 3

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.