[RFE] Global history shouldn't save 404 error pages

RESOLVED DUPLICATE of bug 9203

Status

()

Core
History: Global
--
enhancement
RESOLVED DUPLICATE of bug 9203
17 years ago
17 years ago

People

(Reporter: Alvaro Munoz-Aycuens, Assigned: Blake Ross)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
When you get a 404 from any site, history saves the url of the page with 404
error code.

Expected results:
Mozilla history, should not save the url of pages that are 404.

Steps to reproduce:
1. Type a url of a page that doesn't exist ie: www.aaa.com/tggg
2. You get a 404 error code from the http server
3. go to other site.
4. The error page url is saved on the history.

Tested on:

Windows 98 SE build id: 2001072503
Macos 8.6 build id: 2001072504

Comment 1

17 years ago
IMO, 404 URLs should be saved in global history for the purpose of making links 
to the 404 URL show as visited (purple), but they should be marked as dead so 
they don't show up in URL bar autocomplete.

Comment 2

17 years ago
Marking RFE.
Severity: normal → enhancement
Summary: History shouldn't save 404 error pages → [RFE] History shouldn't save 404 error pages

Comment 3

17 years ago
*** Bug 92984 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Summary: [RFE] History shouldn't save 404 error pages → [RFE] Global history shouldn't save 404 error pages

Comment 4

17 years ago
argh.. take two at reassigning history bugs to new owner
Assignee: alecf → blakeross
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future

Comment 5

17 years ago
looks like a duplicate of bug 9203?
(Reporter)

Comment 6

17 years ago
Yes indeed is a duplicate of the bug, thanks RKAA, i must search bugzilla deeply
:), hmm althought I prefer this bug's summary,

*** This bug has been marked as a duplicate of 9203 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.