Quirks mode triggers table background/border madness

RESOLVED DUPLICATE of bug 31933

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 31933
17 years ago
17 years ago

People

(Reporter: George Lund, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Pages at our site, which have worked fine for literally years (2-ish) in
Internet Explorer, don't work because their doctype, as follows, is somehow (?!)
triggering Mozilla's absurd 'quirks mode'.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd">

The background-color isn't stretching as far as the edge of the padding area,
thus is not reaching the edge of the page. A random border has appeared. An
identical page at
http://lundbooks.co.uk/arts2.html
which uses the strict doctype
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN">

works as intended.

Quirks mode should only be initiated if there is NO doctype, i.e. if the author
is specifically not writing to standards. If the author has tried damn hard to
write standards-compliant code, s/he wants to see standards compliant results!

/RANT

(I am very cross about quirks mode in case you didn't notice. Please please
please abolish it!)
Here is how quirks mode works.  We go into quirks mode for:

1)  No doctype
2)  An HTML < 4.0 doctype
3)  An HTML 4.0 Transitional doctype of any kind (this is an outdated HTML version)
4)  An HTML 4.01 Transitional doctype without a DTD uri

All other doctypes (including 4.01 Transitional with a DTD uri will trigger
strict mode).

So the fix for that particular page is simple.

Please see bug 1312 for lots of discussion on this.

Duplicate of "NavQuirks mode triggered for Transitional documents when not
desired"  (which is wontfix) 

*** This bug has been marked as a duplicate of 31933 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
Thanks for your help - the situation is absurd but it looks like I'll have to
live with it!
You need to log in before you can comment on or make changes to this bug.