Folder pane is empty v24.0

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Adey, Unassigned)

Tracking

({regression})

24 Branch
x86_64
Windows 7
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 813151 [details]
Thunderbird Missing All Folders.PNG

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.76 Safari/537.36

Steps to reproduce:

Uninstalled Thunderbird 12.0, restarted Windows 7 64bit with SP1. Installed Thunderbird 24.0. Open Thunderbird, the left hand folder view is empty and does not respond to right clicks for the context menu. I have backed up my profile from User/me/AppData/local/Thunderbird and deleted it and opened Thunderbird with no change.



  Application Basics

    Name: Thunderbird
    Version: 24.0
    User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.0
    Application Build ID: 20130911175743
    Enabled Plugins: about:plugins
    Build Configuration: about:buildconfig
    Crash Reports: about:crashes
    Memory Use: about:memory

  Mail and News Accounts
    account1:
      INCOMING: account1, , (imap) imaphost.x:993, SSL, passwordCleartext
      OUTGOING: mailhost.x:25, plain, passwordCleartext, true

  Extensions
    Test Pilot for Thunderbird, 1.3.9, true, tbtestpilot@labs.mozilla.com

  Important Modified Preferences

    Name: Value

      browser.cache.disk.capacity: 358400
      browser.cache.disk.smart_size.first_run: false
      browser.cache.disk.smart_size.use_old_max: false
      browser.cache.disk.smart_size_cached_value: 358400
      extensions.lastAppVersion: 24.0
      font.internaluseonly.changed: true
      font.name.monospace.el: Consolas
      font.name.monospace.tr: Consolas
      font.name.monospace.x-baltic: Consolas
      font.name.monospace.x-central-euro: Consolas
      font.name.monospace.x-cyrillic: Consolas
      font.name.monospace.x-unicode: Consolas
      font.name.monospace.x-western: Consolas
      font.name.sans-serif.el: Calibri
      font.name.sans-serif.tr: Calibri
      font.name.sans-serif.x-baltic: Calibri
      font.name.sans-serif.x-central-euro: Calibri
      font.name.sans-serif.x-cyrillic: Calibri
      font.name.sans-serif.x-unicode: Calibri
      font.name.sans-serif.x-western: Calibri
      font.name.serif.el: Cambria
      font.name.serif.tr: Cambria
      font.name.serif.x-baltic: Cambria
      font.name.serif.x-central-euro: Cambria
      font.name.serif.x-cyrillic: Cambria
      font.name.serif.x-unicode: Cambria
      font.name.serif.x-western: Cambria
      font.size.fixed.el: 14
      font.size.fixed.tr: 14
      font.size.fixed.x-baltic: 14
      font.size.fixed.x-central-euro: 14
      font.size.fixed.x-cyrillic: 14
      font.size.fixed.x-unicode: 14
      font.size.fixed.x-western: 14
      font.size.variable.el: 17
      font.size.variable.tr: 17
      font.size.variable.x-baltic: 17
      font.size.variable.x-central-euro: 17
      font.size.variable.x-cyrillic: 17
      font.size.variable.x-unicode: 17
      font.size.variable.x-western: 17
      mail.openMessageBehavior.version: 1
      mailnews.database.global.datastore.id: d3edb744-567d-43c3-8f1c-abe3dbf7756
      places.database.lastMaintenance: 1380536375
      places.history.expiration.transient_current_max_pages: 6192
      plugin.importedState: true
      plugins.update.notifyUser: true

  Graphics

      Adapter Description: Intel(R) HD Graphics
      Vendor ID: 0x8086
      Device ID: 0x0102
      Adapter RAM: Unknown
      Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
      Driver Version: 9.17.10.3062
      Driver Date: 3-8-2013
      Direct2D Enabled: false
      DirectWrite Enabled: false (6.2.9200.16571)
      ClearType Parameters: ClearType parameters not found
      WebGL Renderer: false
      GPU Accelerated Windows: 0

      AzureCanvasBackend: skia
      AzureFallbackCanvasBackend: cairo
      AzureContentBackend: none

  JavaScript

  Incremental GC: 1

  Accessibility

    Activated: 0
    Prevent Accessibility: 0

  Library Versions

      Expected minimum version
      Version in use

      NSPR
      4.10
      4.10

      NSS
      3.15.1 Basic ECC
      3.15.1 Basic ECC

      NSS Util
      3.15.1
      3.15.1

      NSS SSL
      3.15.1 Basic ECC
      3.15.1 Basic ECC

      NSS S/MIME
      3.15.1 Basic ECC
      3.15.1 Basic ECC


Actual results:

Thunderbird loads with no errors. The left hand folder pane is empty and does not respond to rt. clicks for context menu.

Clicking on View settings for this account, displays all of my correct IMAP server details.

I have clicked on View > Layout > Folder Pane so that it is not displayed and then made it display again, it is still empty. I have closed Thunderbird with the pane not displayed and re-opened Thunderbird, the pane is displayed without my intervention.

I have made sure that I have View>Folders>All selected. I have selected the various layouts, vertical, classic, etc with no improvement.

Clicking on Read messages, does nothing. Client is online (icon in bottom left). Write a new message allows me to create an email.

I can send email and it reaches my webmail client. Thunderbird complains when sending it that it can't put it in the Sent mail folder, odd that ;)

I can see local addresses in my Personal address book but not on my Server address book.

Clicking on Manager folder subscriptions, shows that I have no folders that I am subscribed too.


Expected results:

My folder structure should have been read in and displayed.

Comment 1

5 years ago
does starting in safe mode help?
https://support.mozillamessaging.com/en-US/kb/safe-mode
Flags: needinfo?(a.hobsonmerrett)
(Reporter)

Comment 2

5 years ago
It's my work PC so won't be able to try until Monday. I did test as the local administrator and it had the same symptoms. It dual boots Ubuntu so I didn't use Windows today.
(Reporter)

Comment 3

5 years ago
Hello,

I have tried it in safe-mode with networking and I get the same result, no folder panel displayed.
(Reporter)

Comment 4

5 years ago
Sorry, was being thick. Didn't see that you wanted Thunderbird safe mode - did think it a little odd as a test, which is obv. why it states Safe Mode for TB is different :)

I have run it in Thunderbird Safemode and it made no difference. I checked that it was in Safemode as the gude explains, (Add-ons, Extensions).
(Reporter)

Comment 5

5 years ago
Clearing request flag.
(Reporter)

Updated

5 years ago
Flags: needinfo?(a.hobsonmerrett)

Comment 6

5 years ago
Andre this sounds familiar to me. Do you recall related bug or support requests?
Flags: needinfo?(a9016009)
Keywords: regression
Whiteboard: [dupeme]
I'm also seeing this with the home-built nightly.  (It's making it hard to do ui-reviews…  ;)

https://bugzilla.mozilla.org/buglist.cgi?quicksearch=product%3Athunderbird%20empty%20folder%20pane&list_id=9452063 lists some similar bugs, but none of the workarounds seem to help.  Perhaps we dupe this one to bug 912782 and ask Irving to work on it there?
Flags: needinfo?(a9016009)

Comment 8

4 years ago
(In reply to Blake Winton (:bwinton) from comment #7)
> I'm also seeing this with the home-built nightly.  (It's making it hard to
> do ui-reviews…  ;)
> 
> https://bugzilla.mozilla.org/buglist.
> cgi?quicksearch=product%3Athunderbird%20empty%20folder%20pane&list_id=9452063
> lists some similar bugs, but none of the workarounds seem to help.  Perhaps
> we dupe this one to bug 912782 and ask Irving to work on it there?

I've just closed bug 912782.

The most common causes have been addons. On Mac, IMO the next most likely cause out of file handles. 

Are you able to open Address book when this happens?
Flags: needinfo?(bwinton)
Flags: needinfo?(a.hobsonmerrett)
I haven't seen this since, so I guess WFM?
Flags: needinfo?(bwinton)

Updated

4 years ago
Whiteboard: [dupeme] → [closeme 2014-09-25][dupeme]

Comment 10

4 years ago
Resolved per whiteboard and Comment 9
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(a.hobsonmerrett)
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2014-09-25][dupeme] → [dupeme]
You need to log in before you can comment on or make changes to this bug.