In-app payment keys not shown

VERIFIED FIXED

Status

Marketplace
Payments/Refunds
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: andym, Unassigned)

Tracking

x86
Mac OS X
Points:
---

Details

(Reporter)

Description

4 years ago
STR:

* log in to the developer hub
* go to Payment Keys, https://marketplace.firefox.com/developers/in-app-keys/
* press Generate Keys
* note that the page says Application Key (Not yet generated.)

Screenshot:

http://cl.ly/image/2m362y0p1w33

This prevents developers from setting up in-app payments.
(Reporter)

Comment 1

4 years ago
Now I get:

http://sentry.mktmon.services.phx1.mozilla.com/mkt/marketplacefirefoxcom/group/1490/

mkt.developers.views_payments in in_app_keys
MultipleObjectsReturned: get() returned more than one UserInappKey
I just tried this and I was able to see the generated keys if I refreshed the page (I didn't try and generate a second time). Seems the UI should be refreshing and it isn't for some reason.

Also it clearly shouldn't be possible to generate more than one if that's not expected.
(Reporter)

Comment 3

4 years ago
I think its this commit:

https://github.com/mozilla/zamboni/commit/3f44e85e0fbfa8eac1dcb505cba0eb9841bedbfe#diff-5b4589fe747c55cf59dc46e9700fefa6L252

Reverting that and it worked fine for me locally.
(Reporter)

Comment 4

4 years ago
> This prevents developers from setting up in-app payments.


Actually that's not true, real in-app payment keys are stored in solitude. This is stopping developers from testing in-app payments.
Flags: needinfo?(mpillard)
The `uncached` manager was removed because it was confusing to have 2 different ways to disable caching, and also caused bugs because it wasn't following the magic `objects` does, at least on the `Addon` class (it wasn't filtering on addon type correctly, and wasn't filtering out soft-deleted addons)

`no_cache()` should just work. Can we come up with a unit test exhibiting the issue ? Worth noting, we are trying to upgrade django-cache-machine in bug 883477 (there is a PR up) and that might fix some weird issues.
Flags: needinfo?(mpillard)
Took a look at the problem, it turns out it was due to a bug in django-cache-machine 0.6 : it caches count()s even if you call no_cache(). So if you didn't wait 60 seconds you'd get the cached result (which was "no key")

bug 883477 is fixed, so we should now be using django-cache-machine 0.8 on -dev, which should fix this issue. Can you reproduce it now on -dev ?
Flags: needinfo?(amckay)
(Reporter)

Comment 7

4 years ago
Works for me on -dev, thanks Mathieu.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(amckay)
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.