Default plug-in not supported in Mac OS X

VERIFIED FIXED in mozilla0.9.4

Status

()

Core
Plug-ins
P5
blocker
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Chris Petersen, Assigned: Patrick C. Beard)

Tracking

Trunk
mozilla0.9.4
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PDT [OSX+])

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Build: 2001072503
Platform: Mac OS X
Expected Results: Default plug-in should be supported
What I got:Default plug-in isn't loaded by browser

Steps to reproduce:

1) Go to a site that requires a plug-in that's not installed (For example, 
real.com)

2) Default plug-in isn't displayed.

Comment 1

17 years ago
Must be trivial to fix. --> Peter.
Assignee: av → peterl
Summary: Default plug-in not supported in Mac OS X → Default plug-in not supported in Mac OS X

Comment 2

17 years ago
Another bug that would be fixed by bug 83754. I don't know if it's easier to fix
that or covert the nullplugin to a be carbonized.

Brian, do you know how much work it would be to carbonize:
http://lxr.mozilla.org/seamonkey/source/modules/plugin/samples/default/mac
Status: NEW → ASSIGNED
Depends on: 83754
Target Milestone: --- → mozilla0.9.5

Comment 3

17 years ago
It looks like there is already TARGET_CARBON #ifdef code there. I don't know if
there is a target in the project file or not.

I don't imagine this would be terribly difficult, but I haven't done it before
either. :)

Comment 4

17 years ago
Hm..there is tons of TARGET_CARBON code in there and it does seem to build
something which kinda looks like the default plugin. Not sure if the project
file needs to be modified, but there is only one target, "NullPluginPPC" and it
doesn't appear the plugin gets loaded at run-time. 

What is needed to convert a project to build a library to run on CARBON?

Updated

17 years ago
Priority: -- → P5

Comment 5

17 years ago
-->beard
Assignee: peterl → beard
Status: ASSIGNED → NEW
(Assignee)

Comment 6

17 years ago
I will carbonize thetself and get this fixed ASAP.
Severity: normal → blocker
Status: NEW → ASSIGNED
(Assignee)

Comment 7

16 years ago
Created attachment 50990 [details] [diff] [review]
Patch to build NullPluginPPCCarbon target.
(Assignee)

Comment 8

16 years ago
I added a new target to
mozilla/modules/plugin/samples/default/mac/NullPlugin.mcp,  which now uses
MacPrefix.h as its prefix header, so I needed to add additional #includes to
NullPlugin.cpp. Also links against CarbonLib and "MSL C.Carbon.Lib." Building
this target by hand produces a working default plugin which causes the proper
page to come up for downloading the Quicktime plugin when it has been put into
the trash. Please review my trivial patch, and I'll get this checked into trunk
as soon as possible.
Keywords: nsbranch+, patch

Comment 9

16 years ago
Comment on attachment 50990 [details] [diff] [review]
Patch to build NullPluginPPCCarbon target.

r=peterl
Attachment #50990 - Flags: review+
(Assignee)

Comment 10

16 years ago
Created attachment 50995 [details] [diff] [review]
Build system changes to build Carbon target when appropriate.

Comment 11

16 years ago
sr=sfraser on the patches
(Assignee)

Comment 12

16 years ago
Changes checked in on trunk.
(Assignee)

Updated

16 years ago
Whiteboard: PDT [OSX+]

Comment 13

16 years ago
check it in - PDT+
Whiteboard: PDT [OSX+] → [PDT+] [OSX+]
(Assignee)

Comment 14

16 years ago
Changes checked into 094 branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+] [OSX+] → PDT [OSX+]
Target Milestone: mozilla0.9.5 → mozilla0.9.4
(Reporter)

Comment 15

16 years ago
Verified on the Sept 28th Mac OS X branch build. A better url to test it is to
go to http://java.sun.com/. The Netscape Plug-ins dialog should appear with Get
the Plug-in and Cancel buttons.
Keywords: vtrunk

Comment 16

16 years ago
verified default plugins is  on the mac os X branch build 0928 and it works as 
expected when a plugin is missing. adding keyword :vtrunk to verify on trunk l8r
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.