gralloc failed, out of memory will cause the browser to blackout

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: nhirata, Assigned: sotaro)

Tracking

({regression})

26 Branch
ARM
Gonk (Firefox OS)
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

(Whiteboard: [b2g])

Attachments

(2 attachments)

Created attachment 813346 [details]
logcat.txt

Gaia   def8e152db6a317162c03a316f68c409f3af3979
Gecko b955a00f4167
BuildID 20131002004001
Version 26.0a2
Buri

1. launch browser
2. go to http://people.mozilla.com/~nhirata/html_tp/
3. zoom in
4. click on the formsninput.html link 
5. go back, zoom in
6. click on the formsninpu.html link
7. zoom in

Expected: no flickering, content loads
Actual: gralloc fails out of memory, ThebesLayerComposite Layer doesn't have a gralloc buffer and Render aborts causing a black screen or black screen flickering

Note:
1. also occurs on central
Whiteboard: [b2g]
I can confirm I've seen this as well with some of my test pages.
Blocks: 902643
Keywords: regression, regressionwindow-wanted
needinfo'ing :milan to help confirm on the blocking status and also on the assignee as needed.
Flags: needinfo?(milan)
(Assignee)

Comment 3

5 years ago
Handling of out of pmem is going to be fixed in Bug 905882.
- Bug 905882 - Fallback gracefully to system memory when out of PMEM
Assuming this is a near duplicate of bug 905882, but let's get that fixed first and reevaluate this.
Assignee: nobody → sotaro.ikeda.g
blocking-b2g: koi? → koi+
Flags: needinfo?(milan)
(Assignee)

Comment 5

5 years ago
Last week, I already checked the bug STR by using v1.2 hamachi ROM applying Bug 905882, I did not see the black flash.

Updated

5 years ago
QA Contact: mvaughan

Comment 6

5 years ago
This bug does not repro on the latest 1.1 build, and appears to have started on the 9/21/13 1.2 build.

- Does NOT reproduce -
Environmental Variables:
BuildID: 20130920004004
Gaia: 88e73da95f1c550f2fb0572480a40c989d37c997
Gecko: 46b216260c1d
Version: 26.0a2

- Reproduces -
Environmental Variables:
BuildID: 20130921004001
Gaia: 7b6147372cbf560744a02be50e0a862a825caef6
Gecko: 20fe34362674
Version: 26.0a2

Also, this bug seems to have a correlation with the fixing of bug 915747. It appears once the browser stopped forcing a web page back to the top, the flickering started.
Keywords: regressionwindow-wanted
(Assignee)

Updated

5 years ago
Depends on: 905882
Waiting on landing of  Bug 905882 to resolve this,
I see this (not just a flicker, but a layer's contents remaining black) very often with my dynamic toolbar patches (which presumably increase the memory pressure).
Dependency is fixed - can we retest?
Keywords: qawanted
(In reply to Botond Ballo [:botond] from comment #8)
> I see this (not just a flicker, but a layer's contents remaining black) very
> often with my dynamic toolbar patches (which presumably increase the memory
> pressure).

The patch for bug 905882 fixed the problem for me.

Updated

5 years ago
Duplicate of this bug: 933911

Comment 12

5 years ago
This issue reproduces on the Buri 1.2 Build ID: 20131101004000

Gaia   e717aec947571f5daf923c040a82f9f0719bb526
SourceStamp 54de309e18a9
BuildID 20131101004000
Version 26.0

This issue also reproduces on Buri 1.3 Build ID: 20131101040203

Gaia   ccdf357ea150fc7d8b8a4b74c7adf31e7a57e465
SourceStamp abe6790a5dd8
BuildID 20131101040203
Version 28.0a1
Keywords: qawanted
(Assignee)

Comment 13

5 years ago
Sarah, how did you flashed the ROM? Current way of hamachi's ROM flashing seems not update libgralloc and libhwcomposer. Updating them is necessary.
Flags: needinfo?(sparsons)

Comment 14

5 years ago
I have the 20131015 base image and I installed gaia and gecko using the ./fullflash.sh method in Linux. Once the phone is flashed, I factory reset the device.  

(In reply to Sotaro Ikeda [:sotaro] from comment #13)
> Sarah, how did you flashed the ROM? Current way of hamachi's ROM flashing
> seems not update libgralloc and libhwcomposer. Updating them is necessary.
Flags: needinfo?(sparsons)
(Assignee)

Comment 15

5 years ago
./fullflash.sh does not update libgralloc and libhwcomposer. So, can not confirm the fix.
(Assignee)

Comment 16

5 years ago
It seems better to wait hamachi's base image be updated to confirm the fix.

Updated

5 years ago
Duplicate of this bug: 926589
(Assignee)

Updated

5 years ago
Depends on: 934602
(Assignee)

Comment 18

5 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #16)
> It seems better to wait hamachi's base image be updated to confirm the fix.

Bug 934602 is a bug for it.
In the OEM build, instead of blacking out, it skips the layer and whites out:
11-12 11:40:51.940: D/HwcUtils(133): Skip layer
11-12 11:40:52.010: D/HwcUtils(133): Skip layer
11-12 11:41:00.220: D/HwcUtils(133): Skip layer


Gaia   2ef9bc3c7a6de228b63e6ba3613eb0c0dd639c59
BuildID 20131105151351
Version 26.0a2
1.2 Buri

Will test using blobs with our 1.2 gecko/gaia as soon as I'm done testing the OEM build
Adding qawanted to test this with gecko/gaia on top of the OEM build.
Keywords: qawanted

Comment 21

5 years ago
This issue reproduced on the 11/12/2013 1.2 build using the 20131104 base image. I am still seeing the black layers "flicker" on the screen.

Environmental Variables:
Device: Buri v1.2 COM RIL
BuildID: 20131112004004
Gaia: 35b1c6b669b7bf08126df451221113e72642abca
Gecko: 566e850868c7
Version: 26.0
RIL Version: 01.02.00.019.106
Base Image: 20131104
Keywords: qawanted
With the OEM + our gecko/gaia, the pinch zoom and going back/forward on a page seems to change initial view size/location.  I think there's bugs on this, but I would have to double check.  I'm not seeing true white outs.  (ie most of the whiteness I see is because I'm pushed to a location that has tons of white, the white out i saw in the OEM build was completely white for the app including the URL bar and the tool bar at the bottom)

Gaia:     377eb71506d8790d3c3280d82ac007ff4525b7e0
Gecko:    c15f5d7e0d7ebff5f8edef0745f144cd1552e34c
BuildID   20131112123250
Version   28.0a1
Base Build : US_V1.2_20131111.cfg
Buri

I think this one might be resolved as well?
 
The difference in my build is that I took the binaries and built instead of using the releng builds which still are based on the 1.1 blobs.
(Assignee)

Comment 23

5 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #19)
> In the OEM build, instead of blacking out, it skips the layer and whites out:
> 11-12 11:40:51.940: D/HwcUtils(133): Skip layer
> 11-12 11:40:52.010: D/HwcUtils(133): Skip layer
> 11-12 11:41:00.220: D/HwcUtils(133): Skip layer

It seems that fallback to OpenGL rendering seems not working.
(Assignee)

Comment 24

5 years ago
Can we have a logout of the OEM ROM?
How do we proceed with this fix? When can we land this fix?
(Assignee)

Comment 26

5 years ago
Naoki, did you see the following log? When fallbacked gralloc buffer is tried rendering, the following logs appear in logcat.

>  E msm7627a.hwcomposer: hwc_set: Unable to render by hwc due to non-pmem memory
> E HWComposer: H/W Composition failed
> E msm7627a.hwcomposer: hwc_set: Unable to render by hwc due to non-pmem memory
> E HWComposer: H/W Composition failed
> E msm7627a.hwcomposer: hwc_set: Unable to render by hwc due to non-pmem memory
> E HWComposer: H/W Composition failed
Flags: needinfo?(nhirata.bugzilla)
(Assignee)

Comment 27

5 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #26)
> Naoki, did you see the following log? When fallbacked gralloc buffer is
> tried rendering, the following logs appear in logcat.

After failed HWC rendering, layers are rendered by OpenGL.
(Assignee)

Comment 28

5 years ago
Noiki, if you see the log in Comment 26, but see white screen, it seems different problem.
(Assignee)

Updated

5 years ago
Flags: needinfo?(nhirata.bugzilla)
(Assignee)

Comment 29

5 years ago
I flashed the updated ROM. I saw the following log. pmem fallback happens correctly.

> E msm7627a.hwcomposer: hwc_set: Unable to render by hwc due to non-pmem memory
> E HWComposer: H/W Composition failed
(Assignee)

Comment 30

5 years ago
I saw a problematic symptom(incorrect view port?). But I did not see black flash nor white screen on hamachi.
(Assignee)

Comment 31

5 years ago
Created attachment 8333734 [details]
A screen shot of the symptom in Comment 30
(Assignee)

Comment 32

5 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #31)
> Created attachment 8333734 [details]
> A screen shot of the symptom in Comment 30

The symptom was back to normal during touching the drawn area.
(Assignee)

Comment 33

5 years ago
attachment 8333734 [details] seems a different problem.
NI, I suspect the original problem reported in the description is fixed and the problems reported in the comments above are just new issues, correct ? In that case we should marked this bug as fixed and prolly open a new bug here.
Flags: needinfo?(nhirata.bugzilla)
(Assignee)

Comment 35

5 years ago
(In reply to bhavana bajaj [:bajaj] from comment #34)
> NI, I suspect the original problem reported in the description is fixed and
> the problems reported in the comments above are just new issues, correct ?
> In that case we should marked this bug as fixed and prolly open a new bug
> here.

yeah, it's a new bug. I am going to create the bug for it. This week, I am in media playback work week in Auckland. So, there is some delay to create it.
(Assignee)

Comment 36

5 years ago
Bug 934602 is still open. Can QA test this bug?
(Assignee)

Updated

5 years ago
Blocks: 940257
(Assignee)

Comment 37

5 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #32)
> (In reply to Sotaro Ikeda [:sotaro] from comment #31)
> > Created attachment 8333734 [details]
> > A screen shot of the symptom in Comment 30
> 
> The symptom was back to normal during touching the drawn area.

Created Bug 940257 for this symptom.
(Assignee)

Comment 38

5 years ago
By Bug 905882 fixed, I did not see the problem on hamachi. But Bug 934602 is still open. It might affect to the confirmation of the fix.
Keywords: qawanted

Comment 39

5 years ago
This issue still reproduces on Buri 1.2 Build ID: 20131119004006

Gaia   9439907a255e04de4c33493fe03d6670c8256e2f
SourceStamp fe2a7f0db27b
BuildID 20131119004006
Version 26.0

This issue also reproduces on Buri 1.3 Build ID: 20131119040204

Gaia   4ecbc106a3fcf72cbd6dd8a43c46de7bacbedf20
SourceStamp ba9ecdea3a90
BuildID 20131119040204
Version 28.0a1
Keywords: qawanted
(In reply to Sarah Parsons from comment #39)
> This issue still reproduces on Buri 1.2 Build ID: 20131119004006
> 
> Gaia   9439907a255e04de4c33493fe03d6670c8256e2f
> SourceStamp fe2a7f0db27b
> BuildID 20131119004006
> Version 26.0
> 
> This issue also reproduces on Buri 1.3 Build ID: 20131119040204
> 
> Gaia   4ecbc106a3fcf72cbd6dd8a43c46de7bacbedf20
> SourceStamp ba9ecdea3a90
> BuildID 20131119040204
> Version 28.0a1

You need to test this with the 1.2 base image with latest gaia/gecko changes on top to verify this.
Keywords: qawanted
I made my own build and it seems fixed; I would rather wait for the official build to be created and the 1.2 OEM base build used before I mark this confirmed.
Flags: needinfo?(nhirata.bugzilla)

Comment 42

5 years ago
After checking with the latest base (20131115) The issue is no longer reproducing on both 1.2 and 1.3 for Buri.

1.2

Gaia   9439907a255e04de4c33493fe03d6670c8256e2f
SourceStamp fe2a7f0db27b
BuildID 20131119004006
Version 26.0

1.3

Gaia   4ecbc106a3fcf72cbd6dd8a43c46de7bacbedf20
SourceStamp ba9ecdea3a90
BuildID 20131119040204
Version 28.0a1
Keywords: qawanted

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.