Closed Bug 923309 Opened 6 years ago Closed 6 years ago

Firefox is flickery on OS X 10.6 since October 1st

Categories

(Core :: Graphics, defect)

x86_64
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27

People

(Reporter: mconley, Assigned: mattwoodrow)

References

Details

(Keywords: regression)

Attachments

(1 file)

Check out this video of me surfing around on UX: http://www.youtube.com/watch?v=85M2IGcStf4

Watch for the window caption buttons, and the spinners on the tabs.

When I uploaded this video to YouTube, the Flash ads were particularly flickery too, and watching this YouTube video on an affected system was (ironically) *crazy* flickery.

m-c Nightly's have the same effect on tab spinners and the location status indicator. Didn't test YouTube, but I would wager the bug is there as well.

Did mozregression - last good nightly: 2013-09-30, first bad nightly is 2013-10-01.

Pushlog: http://hg.mozilla.org/projects/ux/pushloghtml?fromchange=e62689b72cc6&tochange=9ec16c9a71d3

b83627cebdcd	Matt Woodrow — Bug 921233 - Enabled azure for main-thread drawing on OSX. r=jrmuizel

Was suspect, and setting gfx.content.azure.enabled to false fixed the issue.  Cc'ing both jrmuizel and mattwoodrow. I can't mark this as blocking 921333 because I don't have access to that bug.

Note that I've not tried looking for this bug on 10.7 or 10.8.
Graphics hardware on affected system via about:support

Device ID	0x71c5
GPU Accelerated Windows	0/1 Basic Blocked for your graphics card because of unresolved driver issues.
Vendor ID	0x1002
WebGL Renderer	ATI Technologies Inc. -- ATI Radeon X1600 OpenGL Engine
windowLayerManagerRemote	false
AzureCanvasBackend	quartz
AzureContentBackend	quartz
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated	0
OS: Windows 7 → Mac OS X
Blocks: 921233
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 923650
Whoops - I was just informed that bug 923650 doesn't go away after disabling Azure, so I guess these two are separate issues.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Crazy flickery. This makes Nightly on Mac unusable with default pref of content Azure on.

The pref should be disabled until this is fixed.
Flags: needinfo?(matt.woodrow)
Keywords: regression
We don't need to tell quartz to complete drawing operations with a bitmap context, and this just ends up putting the results on the screen before we want it to.

https://developer.apple.com/library/mac/documentation/GraphicsImaging/Reference/CGContext/Reference/reference.html#//apple_ref/c/func/CGContextFlush
Attachment #815213 - Flags: review?(bas)
Flags: needinfo?(matt.woodrow)
Attachment #815213 - Flags: review?(bas) → review+
(In reply to Dietrich Ayala (:dietrich) from comment #4)
> Crazy flickery. This makes Nightly on Mac unusable with default pref of
> content Azure on.
> 
> The pref should be disabled until this is fixed.

Sidenote, this bug only occurs when you have hardware acceleration disabled.

Do you have them intentionally disabled via pref (layers.acceleration.disabled)? Or are you just using one of the very few macs that have blacklisted/incompatible drivers (custom hardware possibly)?
Assignee: nobody → matt.woodrow
Component: General → Graphics
Product: Firefox → Core
https://hg.mozilla.org/mozilla-central/rev/b73a8fa118dd
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Duplicate of this bug: 924865
(In reply to Matt Woodrow (:mattwoodrow) from comment #6)
> (In reply to Dietrich Ayala (:dietrich) from comment #4)
> > Crazy flickery. This makes Nightly on Mac unusable with default pref of
> > content Azure on.
> > 
> > The pref should be disabled until this is fixed.
> 
> Sidenote, this bug only occurs when you have hardware acceleration disabled.
> 
> Do you have them intentionally disabled via pref
> (layers.acceleration.disabled)? Or are you just using one of the very few
> macs that have blacklisted/incompatible drivers (custom hardware possibly)?

I have a Late 2008 MacBook - aluminium unibody style with an Intel Graphics chipset running 10.7. I don't know about blacklisted/incompatible drivers, but in about:config the value for layers.acceleration.disabled was set to True, and this was seen as the DEFAULT value. Once I set it to False, the flickering did cease.

Is it possible that this is the result of years of upgrading vs fresh installs? In that the default value changed over time - or maybe it's because of migration of the profile from Solaris a while back...

Certainly explains why I wasn't able to track down the flickering issue with mozregression - every nightly I tried with that didn't show the flickering on my
machine.
Duplicate of this bug: 924292
You need to log in before you can comment on or make changes to this bug.