[Meta][User Story] Audio Peer Connection calls (WebRTC P2P)

RESOLVED FIXED in 1.3 C1/1.4 S1(20dec)

Status

Firefox OS
General
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: ITsay, Unassigned)

Tracking

({meta})

unspecified
1.3 C1/1.4 S1(20dec)
x86
Mac OS X
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ucid:WebRTC8, 1.3:p2, ft:webrtc][NPOTB])

(Reporter)

Description

4 years ago
This is the user story meta bug for webRTC.

Audio calls between Firefox OS phones or between Firefox OS & other Firefox products
(Reporter)

Updated

4 years ago
Blocks: 922527
blocking-b2g: --- → 1.3+
Whiteboard: [ucid:WebRTC8, ft:media-recording, 1.3:p1][NPOTB]
(Reporter)

Updated

4 years ago
Keywords: meta
Blocks: 923365

Updated

4 years ago
Flags: in-moztrap?(jsmith)
(Reporter)

Updated

4 years ago
Whiteboard: [ucid:WebRTC8, ft:media-recording, 1.3:p1][NPOTB] → [ucid:WebRTC8, ft:media-recording, 1.3:p1][NPOTB][ft:webrtc]

Updated

4 years ago
No longer depends on: 906968

Updated

4 years ago
Depends on: 870660

Updated

4 years ago
No longer depends on: 916331
Removed items I argue do not block 1.3 (per comments in those bugs).  All of them have been moved from 1.3+ to 1.3? for re-classification (since I did not feel I should just remove the 1.3 nomination entirely, I set them to ? for re-consideration with a recommendation that they *not* block).
No longer depends on: 899204, 919215
I'm having trouble getting the current builds to work reliably (on peak and helix).  I'm running patches 2 & 3 from bug 870660, which makes it possible to connect.  I was unable to connect peerconnections with regular builds; I tried switching to DEBUG builds of gecko and got intermittent connection of http://mozilla.github.com/webrtc-landing/data_test.html.  Note that this requests a fake:true audio channel (though it ignores it); for added fun fake:true channels were broken by some checkins for b2g right before IETF and the fix hasn't landed yet, so the audio would have been real.

gum_test.html works, with reasonable-sounding latency in the uncancelled feedback.

Attempts to connect at apprtc, talky, using pc_test and others did not seem to ever connect.  I was able to get http://mozilla.github.com/webrtc-landing/audio.html to connect I think, but I heard no audio.  Also, there seemed to be problems that required reboots to resolve.

Until I can get actual audio-only peerconnections to connect and play back, I can't test echo cancellation.  I wonder if I'm missing other patches, or if the current patches on 870660 need some more work.
Per discussion offline - targeted features don't block, so we don't need to continue blocking on this.
blocking-b2g: 1.3+ → -

Updated

4 years ago
blocking-b2g: - → ---

Comment 4

4 years ago
Update whiteboard tag to follow format [ucid:{id}, {release}:p{1,2}, ft:{team-id}]
Whiteboard: [ucid:WebRTC8, ft:media-recording, 1.3:p1][NPOTB][ft:webrtc] → [ucid:WebRTC8, 1.3:p1, ft:webrtc][NPOTB]

Updated

4 years ago
Depends on: 945256
(Reporter)

Comment 5

4 years ago
Hi Jason,

Is bug 945256 the feature blocker that prevent us from claiming the feature complete for this one? It seems to me the enabling of perf test option for this feature. Thank you!
Flags: needinfo?(jsmith)
(Reporter)

Comment 6

4 years ago
(In reply to Randell Jesup [:jesup] on PTO until Dec 1 from comment #2)
> I'm having trouble getting the current builds to work reliably (on peak and
> helix).  I'm running patches 2 & 3 from bug 870660, which makes it possible
> to connect.  I was unable to connect peerconnections with regular builds; I
> tried switching to DEBUG builds of gecko and got intermittent connection of
> http://mozilla.github.com/webrtc-landing/data_test.html.  Note that this
> requests a fake:true audio channel (though it ignores it); for added fun
> fake:true channels were broken by some checkins for b2g right before IETF
> and the fix hasn't landed yet, so the audio would have been real.
> 
> gum_test.html works, with reasonable-sounding latency in the uncancelled
> feedback.
> 
> Attempts to connect at apprtc, talky, using pc_test and others did not seem
> to ever connect.  I was able to get
> http://mozilla.github.com/webrtc-landing/audio.html to connect I think, but
> I heard no audio.  Also, there seemed to be problems that required reboots
> to resolve.
> 
> Until I can get actual audio-only peerconnections to connect and play back,
> I can't test echo cancellation.  I wonder if I'm missing other patches, or
> if the current patches on 870660 need some more work.

Hi Randell,

Bug 870660 has been fully landed with 4 patches. I wonder if your question here is still the issue for you?
Flags: needinfo?(rjesup)
(In reply to Ivan Tsay (:ITsay) from comment #5)
> Hi Jason,
> 
> Is bug 945256 the feature blocker that prevent us from claiming the feature
> complete for this one? It seems to me the enabling of perf test option for
> this feature. Thank you!

Yes. We need to actually flip the pref back on in order to declare feature complete. Otherwise, you won't be able to use this feature on the phone by default.
Flags: needinfo?(jsmith)

Updated

4 years ago
Depends on: 945066
(Reporter)

Comment 8

4 years ago
Update to P2 in whiteboard since this is target feature.
Whiteboard: [ucid:WebRTC8, 1.3:p1, ft:webrtc][NPOTB] → [ucid:WebRTC8, 1.3:p2, ft:webrtc][NPOTB]
This is officially a miss for 1.3. Branching has already started, so we're out of time to land this for 1.3. Moving to the 1.4 tracker.
Blocks: 947853
No longer blocks: 922527

Updated

4 years ago
Flags: in-moztrap?(jsmith)
(Reporter)

Comment 10

4 years ago
Update whiteboard to v1.4
Whiteboard: [ucid:WebRTC8, 1.3:p2, ft:webrtc][NPOTB] → [ucid:WebRTC8, 1.4:p2, ft:webrtc][NPOTB]
(Reporter)

Comment 11

4 years ago
Update target milestone to sprint 1 of v1.4
Target Milestone: --- → 1.3 C1/1.4 S1(20dec)
per discussion in Thursday's call - we're going to move back to pushing this into 1.3. If we aren't able to reach an acceptable quality bar, then we'll move to 1.4.
Blocks: 922527
No longer blocks: 947853

Updated

4 years ago
Whiteboard: [ucid:WebRTC8, 1.4:p2, ft:webrtc][NPOTB] → [ucid:WebRTC8, 1.3:p2, ft:webrtc][NPOTB]
I added some basic tests into MozTrap for this to test the browser matrix. This is by no means a full extent analysis of the P2P APIs, but this indicates we've got basic regression coverage in our full test runs.

https://moztrap.mozilla.org/manage/cases/?pagenumber=1&pagesize=20&sortfield=created_on&sortdirection=desc&filter-tag=2514
Flags: in-moztrap+

Updated

4 years ago
No longer depends on: 945256
(Reporter)

Comment 14

3 years ago
Hi Maire/Jason,

I think we should "resolved fixed" this user story bug since all its dependency bugs are close including the Mochitest added for this feature? Any concerns?
Flags: needinfo?(rjesup)
Flags: needinfo?(mreavy)
Flags: needinfo?(jsmith)
Yeah, that's fine.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jsmith)
Resolution: --- → FIXED
Yeah, I agree
Flags: needinfo?(mreavy)
You need to log in before you can comment on or make changes to this bug.