Closed Bug 923434 Opened 6 years ago Closed 6 years ago

panel causes artifacts - especially when scrolling

Categories

(Core :: Graphics, defect)

27 Branch
x86_64
Windows 8
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla28
Tracking Status
firefox27 + verified
firefox28 --- verified

People

(Reporter: gurgardy, Assigned: mattwoodrow)

References

Details

(Keywords: regression, reproducible, Whiteboard: [bugday-20131007])

Attachments

(4 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20131002030201

Steps to reproduce:

the newest nightly build causes artifacts inside panels - especially when scrolling.

to reproduce this behavior, simply try one of the following addons and open their panel through the button in the toolbar:
https://addons.mozilla.org/en-US/firefox/addon/bookrect/
https://addons.mozilla.org/en-US/firefox/addon/gmail-panel/


Actual results:

on windows xp, everything seems to be just fine:
http://youtu.be/xb9GoHRq6UE

but on windows 7 and above (didn't test vista though), rendering isn't working properly:
http://youtu.be/ziIy8m8pwyI
Did it work with the previous Nightly build?
Component: Untriaged → Graphics
Product: Firefox → Core
Whiteboard: [bugday-20131007]
it has been the first time i used a nightly build - so sorry, but i don't know. a user of an addon of me pointed out the artifacts (https://addons.mozilla.org/en-US/firefox/addon/bookrect/reviews/506894/), what led to me using a nightly build the first time.

the artifacts by the way still exists in the newest nightly build.
1. Please try with hardware acceleration disabled (Options → Advanced).
2. You can use mozregression to find the regression range: http://harthur.github.io/mozregression/
the troubleshoot tab is removed in windows 8, so i don't know how to disable hardware acceleration (http://oi41.tinypic.com/2yuj4i0.jpg).

i try to identify the regression range during the next couple of days - sorry that i can't provide them right now, but i am currently quite busy.
(In reply to gurgardy from comment #5)
> the troubleshoot tab is removed in windows 8, so i don't know how to disable
> hardware acceleration (http://oi41.tinypic.com/2yuj4i0.jpg).

I mean the setting in Firefox, it's supposedly in Tools → Options → Advanced → General.
oh ok, sorry for that. just did that and disabling hardware acceleration in firefox makes the artifacts go away.

also used mozregression:
last good nightly: 2013-09-12
first bad nightly: 2013-09-13
I'm going to guess that it's bug 907926 because it's a win gfx change. Although that patch is touching win basic and this bug is with acceleration. Perhaps it had some unintended side effects. Matt?
Flags: needinfo?(matt.woodrow)
I'm hitting this (or a similar issue) frequently when clicking on the 'Downloads' icon, to the right of the search bar. The downloads panel is unreadable half of the time.

Can this be a blocker?
(Note: Nightly 27.0a1 64bit on Ubuntu 12.04 LTS 64bit)
(In reply to Benoit Jacob [:bjacob] from comment #10)
> I'm hitting this (or a similar issue) frequently when clicking on the
> 'Downloads' icon, to the right of the search bar. The downloads panel is
> unreadable half of the time.

Have you checked the regression range?  Maybe it's bug 924650.
Assignee: nobody → matt.woodrow
[Please note that comment 7 has a day-wide regression range.]
This is a regression from https://hg.mozilla.org/mozilla-central/rev/15e9e36b7abc

I'm pretty sure it's a bug with DrawTargetD2D, the attached patch just works around it.

This bug only affects popups when we have acceleration, since that is the only case where we have BasicLayerManager, with D2D content.

I haven't been able to get a recording of this since you need to open a panel instead of just loading a page. Attempting to manually set the global recording prefs resulted in a crash in TLS code.

I also tried to create a moz2d unit test that would show this bug, but haven't been successful there.
Attachment #824532 - Flags: review?(bas)
Flags: needinfo?(matt.woodrow)
An update on trying to get a recording for this:

When I open the panel, I get a crash in RecordedScaledFontCreation::SetFontData.

The ReadFileFragment call in ScaledFontDWrite::GetFontFileData is returning the fileSize for fragmentStart. Then we try copy from this address and crash. To be clear, after the call, fileSize == fragmentStart.

The result returned from ReadFileFragment is S_OK.
Flags: needinfo?(bas)
Attachment #824532 - Attachment is obsolete: true
Attachment #824532 - Flags: review?(bas)
Attachment #826608 - Flags: review?(bas)
Attachment #826608 - Flags: review?(bas) → review+
Attachment #826606 - Flags: review?(bas) → review+
https://hg.mozilla.org/mozilla-central/rev/f65cc31c9745
https://hg.mozilla.org/mozilla-central/rev/c5116411da65
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Target Milestone: mozilla28 → ---
Target Milestone: --- → mozilla28
Depends on: 936792
Comment on attachment 826606 [details] [diff] [review]
Don't use operator source for D2D

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 907926
User impact if declined: Broken scrolling in popups/panels for D2D users.
Testing completed (on m-c, etc.): Been on m-c for a while, manually confirmed the fix.
Risk to taking this patch (and alternatives if risky): Low risk, should just revert to the existing behaviour for d2d.
String or IDL/UUID changes made by this patch: None
Attachment #826606 - Flags: approval-mozilla-aurora?
Attachment #826606 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 946186
Depends on: 946475
No longer depends on: 936792
gurgardy, can you please verify this is fixed in Firefox 27 and 28?
Flags: needinfo?(gurgardy)
i did just test it and the bug has been fixed in current beta, aurora and nightly

thanks!
Flags: needinfo?(gurgardy)
(In reply to gurgardy from comment #23)

Thanks for your help.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.