crash when selecting print without lp configured - Trunk & N610 crash [@ libc.so.6 - nsPostScriptObj::begin_document]

VERIFIED WORKSFORME

Status

MailNews Core
Printing
--
major
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Karen Huang, Assigned: dcone (gone))

Tracking

({crash, topcrash})

Trunk
mozilla0.9.5
x86
Linux
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
crash when selecting print without define the printer

Used 07-25-04-0.9.2 Linux build

1) Login to mail
2) Select the mail msgs from Inbox
3) Select Print with the default lpr (without define to "lpr -Pprintername" yet)
4) Actual Results: Crash

Expected results: Should just not doing anything without the crash since the
printer didn't point to the right printer.
(Reporter)

Comment 1

17 years ago
adding keywords: crash, please check the URL for the taklback report
Severity: normal → major
Keywords: crash

Comment 2

17 years ago
Created attachment 43602 [details]
talkback report

Comment 3

17 years ago
Karen/Esther, do you think this could be a DUP of 78948...can you check?
what version of linux are you running? is it RH 6.2? also check
and see if you crash printing from browser.

Comment 4

17 years ago
Karen/Esther, marking a DUP of 78948. My bet is you will crash when
printing from the browser also. and you must be using RedHat 6.2 system.
Also changing qa_contact to myself and adding esther as cc:

*** This bug has been marked as a duplicate of 78948 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
QA Contact: esther → sujay
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

17 years ago
I was using Linux 6.1, and it did crash on browser too.
(Reporter)

Comment 6

17 years ago
Reopening this bug since this crash is occurring when you print "without" define 
printer.....After I define "lpr -Pprintername" won't get the crash.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 7

17 years ago
Nominating nsbeta1
Keywords: nsbeta1

Comment 8

17 years ago
cc: syd and krtizer....this is the bug having to do with crashing
when  Linux printing crashes if "lp" printer is not configured.

Comment 9

17 years ago
FYI= I release noted this in release note bug 90577:

Bug 78948 and Bug 92344

You may experience print failures, or a crash on RedHat linux if you try to 
print to a printer, but do not have a printer named lp configured. There are two 
ways to work around this. 

1) Configure the printer named lp (which is by default the printer name assigned 
on Redhat Linux).

2) Use a printer that is configured, e.g., lp0, by changing the print command in 
the print dialog so that it reads lpr -P lp0 (replace lp0 with the name of your 
printer). 

To see the list of configured printers, you can log in as root and use the 
following command: 'lpc status'. Alternately, you can use the RedHat 'printtool' 
application to graphically view and configure the printers on your system.

Comment 10

17 years ago
changing summary
Summary: crash when selecting print without define the printer → crash when selecting print without lp configured

Comment 11

17 years ago
In 4.x if lp is not definted, it throws up an error panel with something
like this: "Error: lp is not defined", something to this effect.

Comment 12

17 years ago
Adding N610 crash [@ libc.so.6 - nsPostScriptObj::begin_document] to summary for
tracking.  Although we know the problem and the "fix" has been release noted, I
still feel this will be a topcrasher for the N610 release...but leaving the
keyword out until we get more Talkback data.

huang@netscape.com has already crashed a couple of times testing this with the
final N610 Linux build 2001072504.  Here is her latest entry in case anyone
needs to look at it:

Incident ID 33341296
Stack Signature libc.so.6 + 0xa4df4 (0x404c2df4) 5b38b64e
Bug ID 92344
Trigger Time 2001-07-25 16:34:10
User Comments crash if without define the printer
Build ID 2001072504
Product ID Netscape6.10
Platform ID LinuxIntel
Stack Trace
libc.so.6 + 0xa4df4 (0x404c2df4)
libc.so.6 + 0x55634 (0x40473634)
libc.so.6 + 0x55714 (0x40473714)
libc.so.6 + 0x551d0 (0x404731d0)
libc.so.6 + 0x5488e (0x4047288e)
libc.so.6 + 0x56017 (0x40474017)
libc.so.6 + 0x54f10 (0x40472f10)
libc.so.6 + 0x45098 (0x40463098)
libc.so.6 + 0x4cf47 (0x4046af47)
nsPostScriptObj::begin_document()
nsPostScriptObj::Init()
nsDeviceContextPS::BeginDocument()
DocumentViewerImpl::SetupToPrintContent()
DocumentViewerImpl::DocumentReadyForPrinting()
DocumentViewerImpl::Print()
nsMsgPrintEngine::OnStateChange()
nsDocLoaderImpl::FireOnStateChange()
nsDocLoaderImpl::doStopDocumentLoad()
nsDocLoaderImpl::DocLoaderIsEmpty()
nsDocLoaderImpl::OnStopRequest()
nsLoadGroup::RemoveRequest()
PresShell::RemoveDummyLayoutRequest()
PresShell::DoneRemovingReflowCommands()
PresShell::ProcessReflowCommands()
HandlePLEvent()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0xe52a (0x4033d52a)
libglib-1.2.so.0 + 0xfbe6 (0x4033ebe6)
libglib-1.2.so.0 + 0x101a1 (0x4033f1a1)
libglib-1.2.so.0 + 0x10341 (0x4033f341)
libgtk-1.2.so.0 + 0x8c209 (0x40266209)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x181eb (0x404361eb) 

Could we prevent the crash by throwing up an error message like sujay mentioned?
Summary: crash when selecting print without lp configured → crash when selecting print without lp configured - N610 crash [@ libc.so.6 - nsPostScriptObj::begin_document]

Comment 13

17 years ago
target = 0.9.4 per dcone

properly configured systems won't experience this. If someone
has an un-configured system or a mis-configured system they'll
get the crash...we have release notes for a workaround.
Target Milestone: --- → mozilla0.9.4
(Reporter)

Comment 14

17 years ago
>properly configured systems won't experience this. If someone
>has an un-configured system or a mis-configured system they'll
>get the crash...we have release notes for a workaround.

In 4.x, will prompt "lpr: lp: unknown printer". 
No matter how, users shouldn't crash WITHOUT any setting from the printer.

I have the same feeling as jpatel that this should be a topcrasher for the N610 
release.....


Comment 15

17 years ago
related or dup of bug 91329 ?

Comment 16

17 years ago
*** Bug 91329 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
cc: ylong, she filed a bug that got DUP'd to this one.

Comment 18

17 years ago
*** Bug 86464 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Comment 19

17 years ago
This is indeed a topcrasher for Netscape 6.10 and is also showing up in the
MozillaTrunk topcrash reports.  Adding Trunk to summary for tracking.  I guess
the target milestone got pushed to M095...so hopefully we'll get this fixed by then.
Summary: crash when selecting print without lp configured - N610 crash [@ libc.so.6 - nsPostScriptObj::begin_document] → crash when selecting print without lp configured - Trunk & N610 crash [@ libc.so.6 - nsPostScriptObj::begin_document]

Updated

17 years ago
Keywords: topcrash
So is this just because the patch to bug 78948 was never checked in on the trunk?

Comment 21

17 years ago
dbaron: yes, this crash is probably still around b/c the fix wasn't checked into
the trunk back in july.  dcone and syd might want to discuss whether or not to
check that fix into the trunk now.
Don's not available. Syd will the patch for bug 78948 fix this?

Comment 23

17 years ago
I don't have any evidence that this is related to 78948 -- has someone verified
that applying that patch will actually fix the problem?
My machine is NOT set up to handle lpr correctly
Using a trunk build from today on Linux I do not get a crash when printing. I
also tried printing to a file in a non-existent directory. It also did not
crash. Instead an alert dialog notifying me that the print request had failed.

Marking WORKSFORME.

Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 25

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ libc.so.6 - nsPostScriptObj::begin_document]
You need to log in before you can comment on or make changes to this bug.