All users were logged out of Bugzilla on October 13th, 2018

[B2G][Everything.me][Marketplace] Launching Bubble Meadow then going home causes a homescreen orientation issue

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: KTucker, Assigned: gerard-majax)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [e.me 1.2 test run][systemsfe])

Attachments

(3 attachments)

Created attachment 813569 [details]
bublemeadowlog.txt

Description:
Launching Bubble Meadow then going home causes the homescreen to appear in landscape mode.

Repro Steps:
1)  Updated Buri Build ID: 20131003040204
2)  Open "Marketplace".
3)  Tap on "Bubble Meadow".
4)  Tap on "Free" and then "Install".
5)  Tap the "Home Button" on the phone and launch "Bubble Meadow".
6)  Immediately press the "Home Button" on the phone after launching "Bubble Meadow" and observe the homescreen.
7)  If the issue does not occur, repeat step 6.

Actual:
The homescreen orientation will appear in landscape mode.

Expected:
The homescreen orientation appears in portrait mode without issue.

Environmental Variables
Device:  Buri v 1.3.0 Mozilla RIL
Build ID: 20131003040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/0e26e6f12ad9
Gaia: dc68f530ca7d1b182deef0a3787cfdd8f0778612
Platform Version: 27.0a1
RIL Version: 01.02.00.019.056 

Notes:
Repro frequency: 100%
See attached: screenshot, logcat
Created attachment 813572 [details]
Landscape Homescreen pic
(Reporter)

Updated

5 years ago
Blocks: 910302
Please note that taking a screenshot immediately when the homescreen orientation is in landscape mode causes the homescreen to remain in landscape mode.
Component: Gaia::Everything.me → Gaia::System
Unrelated to e.me. This does sound bad though. Can you reproduce on 1.1?
No longer blocks: 910302
Component: Gaia::System → Gaia::Homescreen
Keywords: qawanted
I'm going to operate under the assumption this is a regression because we've had and fixed bugs around this previously. Double check though this doesn't reproduce on 1.1 to confirm.
blocking-b2g: --- → koi?
Keywords: qawanted → regression, regressionwindow-wanted

Updated

5 years ago
QA Contact: sparsons
AFAIK the orientation is an issue not related to apps (homescreen, contacts, ...). It belongs to system app

Updated

5 years ago
Component: Gaia::Homescreen → Gaia::System

Comment 6

5 years ago
Multiple issues started to occur with this app on the 9/05 Buri 1.2 Build ID: 20130905185329

Gaia   b77dc7d399c14ac2bafe5c89566b292bc6772d32
SourceStamp df8f342e9a6b
BuildID 20130905185329
Version 26.0a1

Issues include the home screen orientation issue and an error that occurs that says "Install failed, error: MULTIPLE_APPS_PER_ORIGIN_FORBIDDEN

Unable to flash to Buri builds 9/03 and 9/04 because they are broken.

Last working build Buri 1.2 Build ID: 20130902040202

Gaia   0457c197a382a219b1050fd2ccfddfdbbdad7a92
SourceStamp 1179318fb5aa
BuildID 20130902040202
Version 26.0a1


See logcat attached.

Comment 7

5 years ago
Created attachment 814179 [details]
BubbleMeadowLogcat.txt

Updated

5 years ago
Keywords: regressionwindow-wanted
blocking-b2g: koi? → koi+
NI on :gwagner to help with an assignee here.
Flags: needinfo?(anygregor)
Flags: needinfo?(anygregor)
Whiteboard: e.me 1.2 test run → [e.me 1.2 test run][systemsfe]
(Assignee)

Comment 9

5 years ago
I'll look into this.
(Assignee)

Updated

5 years ago
Assignee: nobody → lissyx+mozillians
(Assignee)

Comment 10

5 years ago
I am unable to reproduce this issue on an Inari with Gecko 26 and Gaia v1.2.
How often does this reproduce?
Flags: needinfo?(ktucker)
(In reply to Alexandre LISSY :gerard-majax (off 16/09-14/10) from comment #10)
> I am unable to reproduce this issue on an Inari with Gecko 26 and Gaia v1.2.

Did you try on Buri by any chance? This bug reproduces on Buri, not Inari.
(Assignee)

Comment 13

5 years ago
(In reply to Jason Smith [:jsmith] from comment #12)
> (In reply to Alexandre LISSY :gerard-majax (off 16/09-14/10) from comment
> #10)
> > I am unable to reproduce this issue on an Inari with Gecko 26 and Gaia v1.2.
> 
> Did you try on Buri by any chance? This bug reproduces on Buri, not Inari.

Nope, unfortunately I don't have a buri. I did not tried on Leo either. I can give a try on the following other devices, though:
 - peak
 - keon
 - nexus s (early v1.2 from august, though)
 - inari
 - leo
(In reply to Alexandre LISSY :gerard-majax (off 16/09-14/10) from comment #13)
> (In reply to Jason Smith [:jsmith] from comment #12)
> > (In reply to Alexandre LISSY :gerard-majax (off 16/09-14/10) from comment
> > #10)
> > > I am unable to reproduce this issue on an Inari with Gecko 26 and Gaia v1.2.
> > 
> > Did you try on Buri by any chance? This bug reproduces on Buri, not Inari.
> 
> Nope, unfortunately I don't have a buri. I did not tried on Leo either. I
> can give a try on the following other devices, though:
>  - peak
>  - keon
>  - nexus s (early v1.2 from august, though)
>  - inari
>  - leo

Okay. I'd suggest trying leo then - it's a target 1.2 production device.
I reproduce this 100% of the time on the latest Buri v 1.3.0 Mozilla RILL

Environmental Variables
Device: Buri v 1.3.0 Mozilla RIL
Build ID: 20131017040202
Gecko: http://hg.mozilla.org/mozilla-central/rev/423b9c30c73d
Gaia: 616e87af0133496620aea89f21ca5d37acedf466
Platform Version: 27.0a1

Launch Bubble Meadow, tap the "Home Button" on the phone and notice the home screen orientation appears in landscape mode for a few seconds or the user will get the error "Install failed, error: MULTIPLE_APPS_PER_ORIGIN_FORBIDDEN".
Flags: needinfo?(ktucker)
(Assignee)

Comment 16

5 years ago
(In reply to Jason Smith [:jsmith] from comment #14)
> (In reply to Alexandre LISSY :gerard-majax (off 16/09-14/10) from comment
> #13)
> > (In reply to Jason Smith [:jsmith] from comment #12)
> > > (In reply to Alexandre LISSY :gerard-majax (off 16/09-14/10) from comment
> > > #10)
> > > > I am unable to reproduce this issue on an Inari with Gecko 26 and Gaia v1.2.
> > > 
> > > Did you try on Buri by any chance? This bug reproduces on Buri, not Inari.
> > 
> > Nope, unfortunately I don't have a buri. I did not tried on Leo either. I
> > can give a try on the following other devices, though:
> >  - peak
> >  - keon
> >  - nexus s (early v1.2 from august, though)
> >  - inari
> >  - leo
> 
> Okay. I'd suggest trying leo then - it's a target 1.2 production device.

Okay, I'm updating my leo now with new gecko and gaia.
(Assignee)

Comment 17

5 years ago
Rebuilt from scratch a full image for leo, flashed gecko and gaia, touchscreen is broken. I can't test this.
(Assignee)

Comment 18

5 years ago
(In reply to Alexandre LISSY :gerard-majax (off 16/09-14/10) from comment #17)
> Rebuilt from scratch a full image for leo, flashed gecko and gaia,
> touchscreen is broken. I can't test this.

Fixed the touchscreen, I'm still fighting with this device, b2g does not come up to gaia ...
(Assignee)

Comment 19

5 years ago
Okay, I'm fed up with this, I lost already several hours just getting a Leo device usable with Wi-Fi. Everything is broken everywhere, even pvtbuilds are not working.
FWIW - If you are hitting leo setup problems, I'd suggest talking to nhirata about this.
(Assignee)

Comment 21

5 years ago
(In reply to Jason Smith [:jsmith] from comment #20)
> FWIW - If you are hitting leo setup problems, I'd suggest talking to nhirata
> about this.

I finally got leo working ... And I'm reproducing the issue.
(Assignee)

Comment 22

5 years ago
(In reply to ktucker from comment #15)
> I reproduce this 100% of the time on the latest Buri v 1.3.0 Mozilla RILL
> 
> Environmental Variables
> Device: Buri v 1.3.0 Mozilla RIL
> Build ID: 20131017040202
> Gecko: http://hg.mozilla.org/mozilla-central/rev/423b9c30c73d
> Gaia: 616e87af0133496620aea89f21ca5d37acedf466
> Platform Version: 27.0a1
> 
> Launch Bubble Meadow, tap the "Home Button" on the phone and notice the home
> screen orientation appears in landscape mode for a few seconds or the user
> will get the error "Install failed, error:
> MULTIPLE_APPS_PER_ORIGIN_FORBIDDEN".

I am reproducing this on both devices. I don't have the screen in landscape on the Inari, but I feel some lag on the Leo device which exposes the issue of landscape for a couple of seconds. So I'm wondering that maybe the Inari just hides it.

You report about two issues here: landscape, and the error message. I'm a bit lost.
Flags: needinfo?(ktucker)
(In reply to Alexandre LISSY :gerard-majax (off 16/09-14/10) from comment #22)
> (In reply to ktucker from comment #15)
> > I reproduce this 100% of the time on the latest Buri v 1.3.0 Mozilla RILL
> > 
> > Environmental Variables
> > Device: Buri v 1.3.0 Mozilla RIL
> > Build ID: 20131017040202
> > Gecko: http://hg.mozilla.org/mozilla-central/rev/423b9c30c73d
> > Gaia: 616e87af0133496620aea89f21ca5d37acedf466
> > Platform Version: 27.0a1
> > 
> > Launch Bubble Meadow, tap the "Home Button" on the phone and notice the home
> > screen orientation appears in landscape mode for a few seconds or the user
> > will get the error "Install failed, error:
> > MULTIPLE_APPS_PER_ORIGIN_FORBIDDEN".
> 
> I am reproducing this on both devices. I don't have the screen in landscape
> on the Inari, but I feel some lag on the Leo device which exposes the issue
> of landscape for a couple of seconds. So I'm wondering that maybe the Inari
> just hides it.
> 
> You report about two issues here: landscape, and the error message. I'm a
> bit lost.

It's the landscape issue, not the error message.
Flags: needinfo?(ktucker)
(Assignee)

Comment 24

5 years ago
I'm currently bisecting the proposed interval of versions:
good 57dd086a1d7999eb8240f95f12eb865892726824
bad  afcdd911d24cf1187ba72bc28e49faf0d3d1d48c
(Assignee)

Comment 25

5 years ago
(In reply to Alexandre LISSY :gerard-majax (off 16/09-14/10) from comment #24)
> I'm currently bisecting the proposed interval of versions:
> good 57dd086a1d7999eb8240f95f12eb865892726824
> bad  afcdd911d24cf1187ba72bc28e49faf0d3d1d48c

I've bisected this whole interval, unable to reproduce the bug. So I'm tempted to say that the issue is not on Gecko's side.

All the bisect iterations were done against Gaia 0457c197a382a219b1050fd2ccfddfdbbdad7a92
(Assignee)

Comment 26

5 years ago
(In reply to Alexandre LISSY :gerard-majax (off 16/09-14/10) from comment #25)
> (In reply to Alexandre LISSY :gerard-majax (off 16/09-14/10) from comment
> #24)
> > I'm currently bisecting the proposed interval of versions:
> > good 57dd086a1d7999eb8240f95f12eb865892726824
> > bad  afcdd911d24cf1187ba72bc28e49faf0d3d1d48c
> 
> I've bisected this whole interval, unable to reproduce the bug. So I'm
> tempted to say that the issue is not on Gecko's side.
> 
> All the bisect iterations were done against Gaia
> 0457c197a382a219b1050fd2ccfddfdbbdad7a92

I did the bisect of Gaia in the train, against Gecko afcdd911d24cf1187ba72bc28e49faf0d3d1d48c (latest one, should be the buggy one), and I could not reproduce the bug.

So either there is something broken about the proposed window of reproductibility, or this bug is also dependant on network/content of the app ...
Probably more likely that the regression window needs to be fixed. Flagging again to check again. Specifically, the window needs to focus on the timeframe of when the landscape issue specifically last worked & first failed.
Keywords: regressionwindow-wanted

Updated

5 years ago
QA Contact: sparsons → nkot

Comment 28

5 years ago
I'm wondering if this is the same issue as bug 925421...
(In reply to nkot from comment #28)
> I'm wondering if this is the same issue as bug 925421...

Don't think so. That issue is only reproducing on 1.3, not 1.2.
(Assignee)

Comment 30

5 years ago
So, bisecting gaia with network, still no bad commit found :(
(Assignee)

Comment 31

5 years ago
None of the prebuilt pvtbuilds are exposing the issue, latest one I could test was 20130915.
(Assignee)

Comment 32

5 years ago
And now I cannot reproduce it with any build I can find. I'm out of this until we have a better picture.
Flags: needinfo?(ktucker)
(Assignee)

Comment 33

5 years ago
Took Julien's Buri, flashed gecko/gaia of 20130914, and when launching the app, now, I can't tap on the OK button if the error message nor even tap on the home button ...
(Assignee)

Comment 34

5 years ago
I also see this on the buri. E/GeckoConsole(  703): [JavaScript Error: "[Exception... "The operation is insecure."  code: "18" nsresult: "0x80530012 (SecurityError)"  location: "<unknown>"]"]
(Assignee)

Comment 35

5 years ago
(In reply to Alexandre LISSY :gerard-majax (off 16/09-14/10) from comment #33)
> Took Julien's Buri, flashed gecko/gaia of 20130914, and when launching the
> app, now, I can't tap on the OK button if the error message nor even tap on
> the home button ...

With a build from today, on buri, and installing directly the application from the marketplace, I still cannot reproduce the landscape issue.
(Assignee)

Comment 36

5 years ago
(In reply to Alexandre LISSY :gerard-majax (off 16/09-14/10) from comment #35)
> (In reply to Alexandre LISSY :gerard-majax (off 16/09-14/10) from comment
> #33)
> > Took Julien's Buri, flashed gecko/gaia of 20130914, and when launching the
> > app, now, I can't tap on the OK button if the error message nor even tap on
> > the home button ...
> 
> With a build from today, on buri, and installing directly the application
> from the marketplace, I still cannot reproduce the landscape issue.

NOT FROM THE MARKETPLACE, from the website.

Comment 37

5 years ago
apparently, we have two issues mixed up in this bug

1. landscape issue - NO longer reproduces! on 09/18 v1.3 build
in fact, landscape issue was not specific to Bubble Meadow game, games as Poppit and Zombie Lines were affected as well and they all work fine now, see also bug 925421

2. the error message - still reproduces!
this is Bubble Meadow specific issue - the app can be installed but when launched shows the error, 
when tap "OK" on the error message it display loading Bubble Meadow screen stuck on 20%,
when tap home button the game with will exit-minimize successfully

tested on Buri
BuildID: 20131018040217
Gaia: 18c2ab4b7b2d4cacee90fb85e97354142b2fad4a
Gecko: 855da6d8a327
Version: 27.0a1

Should we concentrate on the second issue in this bug then? If so i will try to find a regression window
Flags: needinfo?(ktucker)

Comment 38

5 years ago
could not test on the latest 1.3 build due to a bug 928976
Sounds like this is wfm. Can you open a separate bug for the second issue?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME

Comment 40

5 years ago
(In reply to Jason Smith [:jsmith] from comment #39)
> Sounds like this is wfm. Can you open a separate bug for the second issue?

just so we finish here, I've tested on Buri aurora as well - got same results as in comment 37

BuildID: 20131022004000
Gaia: 00d5964eabf95a6a8a632420dfa36fc76dcbc9b7
Gecko: 7453a764f9a9
Version: 26.0a2

and I will file another bug for the second issue
blocking-b2g: koi+ → ---
You need to log in before you can comment on or make changes to this bug.