If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Overlay on urlbar no longer produces icon, since Firefox 24

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: Ian Nartowicz, Unassigned)

Tracking

24 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20131021])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 813596 [details]
cookieController.xpi

User Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0 (Beta/Release)
Build ID: 20130911042038

Steps to reproduce:

The attached minimal addon overlays an hbox containing an image on the urlbar, just before the urlbar-icons hbox.  Load this into Firefox 24 or a later version.


Actual results:

No image appears.


Expected results:

A (large!) icon should appear inside the urlbar textbox just before the star.  This worked until Firefox 24.  Now DOM Inspector shows me the overlaid image (zero size, as if hidden) if I inspect without anonymous nodes visible, but it disappears when anonymous nodes are inspected.  Something to do with the way children are merged into XML bindings>
(Reporter)

Comment 1

4 years ago
Further info: if I open the toolbar palette, the overlaid image appears, and it remains after I close the palette.  Even if I don't make any customisation changes.
(Reporter)

Comment 2

4 years ago
And the real reason :(  The following line of javascript executed in each window:
document.getElementById("urlbar").setAttribute("autocompletesearchparam","");

Not sure if this counts as a bug any more?  Still seems odd and still a regression.
(Reporter)

Comment 3

4 years ago
Created attachment 813985 [details]
Children of the urlbar binding, including the box with an image

Added screenshots showing what DOM Inspector sees.
(Reporter)

Comment 4

4 years ago
Created attachment 813986 [details]
Shwoign anonymous nodes, now hbox with image does not exist

Comment 5

4 years ago
WFM with:
2013-01-04-03-08-23-mozilla-central-firefox-20.0a1.en-US.linux-x86_64
2013-06-24-03-10-40-mozilla-central-firefox-24.0a1.en-US.linux-x86_64
firefox-24.0.en-US.linux64
2013-07-01-03-11-15-mozilla-central-firefox-25.0a1.en-US.linux-x86_64
2013-10-21-03-02-03-mozilla-central-firefox-27.0a1.en-US.linux-x86_64
Whiteboard: [bugday-20131021]
Works for me on:
46.0a1 Build ID 	20160111030207 | Mozilla/5.0 (X11; Linux i686; rv:46.0) Gecko/20100101 Firefox/46.0

Note: Guessing that the quality of icon is not in question here, just the fact that is visible.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.