CSS transition failed on DOM change parent element style overflow: hidden

RESOLVED DUPLICATE of bug 625289

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 625289
5 years ago
5 years ago

People

(Reporter: Binyamin, Unassigned)

Tracking

27 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.66 Safari/537.36

Steps to reproduce:

Toggle class name with overflow: hidden to parent element of transition animated element.

Test-case http://jsbin.com/eZOsEja/3/edit (Click on link to check if transition is affected).


Actual results:

No CSS transition is fired.


Expected results:

Run transition.
The bug does not appears on any other browser that is not related to Mozilla.
(Reporter)

Updated

5 years ago
(Reporter)

Updated

5 years ago
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
Binyamin, thank you for the bug report!  This is part of a general class of problems where style changes on a parent that need to reconstruct its CSS box inhibit transitions on the child.  :(
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 625289
(Reporter)

Comment 2

5 years ago
(In reply to Boris Zbarsky [:bz] from comment #1)
> *** This bug has been marked as a duplicate of bug 625289 ***
#625289 seems related to CSS position change. This bug #923538 is related to overflow: hidden.
You need to log in before you can comment on or make changes to this bug.