Loading forever, progress indicator(tab icon) is continue spinning on certain site

RESOLVED DUPLICATE of bug 81980

Status

()

defect
RESOLVED DUPLICATE of bug 81980
6 years ago
6 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/0e26e6f12ad9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131003030203

Steps To Reproduce:
1. Open https://commondatastorage.googleapis.com/chromium-browser-snapshots/index.html?path=Win/

Actual Results:
Loading forever.
Progress indicator(tab icon) is continue spinning.

Comment 1

6 years ago
Reproducible on:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (20131025030239)
Status: UNCONFIRMED → NEW
Component: General → Networking
Ever confirmed: true
Product: Firefox → Core
I think this is more of a docshell issue.. but I could be wrong.

the base page is just a bunch of js that engages in a more or less endless loop of async xhr. I'm not positive if the spinner is supposed to spin when async xhr is going on.
Component: Networking → Document Navigation
It ... depends.

XHR does background loads (which ought not to spin the spinner), I thought, unless people are using progress listeners or some such.

But is the XHR what keeps the spinner going in this case?  Seems to me like it's the fact that the page is rewritten with document.write() (with an implied document.open() not followed by document.close()).  As in, this is a duplicate of bug 81980 and company.  And for that matter, of bug 771270, on the same URI.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 81980
You need to log in before you can comment on or make changes to this bug.