Don't show 'protect tab' or 'lock tab' indicators on a pinned tab

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Eoghan Murray, Unassigned)

Tracking

25 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/28.0.1500.71 Chrome/28.0.1500.71 Safari/537.36

Steps to reproduce:

Upgraded to 25.0a2 (Aurora Channel)
Recreated my pinned tabs for Gmail and Soundcloud
Soon after, I accidentally clicked a link which resulted in the Soundcloud tab being replaced by another url.
Realized I hadn't set up 'protect tab' and 'lock tab' on the pinned tab, so did so.


Actual results:

Pinned tab showed 'protect tab' and 'lock tab' indicators, covering 50% of the favicon and making it very difficult to distinguish between the Gmail and Soundcloud pinned tabs.


Expected results:

Because of the limited space, applying 'protect tab' and 'lock tab' to a pinned tab should not have resulted in any extra indicators on the tab.

I'm not sure what the intended behavior is but I'm pretty sure there is a regression here:
In my pre-25 Aurora, it was either
 - pinned tabs didn't show these indicators
or
 - pinned tabs automatically applied/inherited the 'lock tab' behaviour (and I didn't manually lock the tab)

For the record, I think it makes sense that pinned tabs would also automatically be locked, assuming they are intended to be 'apps'.
This is an addon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.