If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Rename 'Lock Tab' and 'Protect Tab'

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Eoghan Murray, Unassigned)

Tracking

25 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/28.0.1500.71 Chrome/28.0.1500.71 Safari/537.36

Steps to reproduce:

Right clicked on a tab


Actual results:

Saw 'lock tab' and 'protect tab' and was instantly confused, just like the (tens of?) thousands of other English speaking Firefox users who ignored these items and got on with their day instead of filing a bugzilla :)


Expected results:

'protect' and 'lock' are almost perfect synonyms in English.  

The names should provide more information on what they do.
Suggestions:
'Prevent accidental closure'
'Lock tab to url'

I'm sure there are nuances where these descriptions don't apply (e.g. 'Lock Tab' actually allows url modification via the history api — which is is what I want in the context of an app), but unless these are not the intended behavior of this functionality, I think a rename along these lines is an improvement!
I believe the names "Protect Tab" and "Lock Tab" are deliberate. These are basically integrating features already found in many tab management addons into Firefox itself. However, if you believe you have better names, please feel free to suggest them in the firefox-dev mailing list where they can be discussed.
Wait, never mind. You *are* using an addon. This isn't a core feature of Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
OS: Linux → All
Hardware: x86 → All
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.