Closed Bug 923629 Opened 6 years ago Closed 6 years ago

[User Story] [DSDS] Import contacts from each SIM at a time

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect, P1, blocker)

x86
macOS
defect

Tracking

(blocking-b2g:1.3+)

VERIFIED FIXED
1.3 Sprint 6 - 12/6
blocking-b2g 1.3+

People

(Reporter: wmathanaraj, Assigned: arcturus)

References

()

Details

(Keywords: feature, Whiteboard: [ucid:Comms36, ucid:DSDS20, 1.3:p1, FT:comms])

User Story:

As I user, I should be able to import contacts from each SIM at a time from the primary SIM.

Acceptance Criteria:

* I am able to import contacts from the primary SIMs
* I am able to import contacts from the SIM after changing the primary SIM setting 
* I am able to see all the contacts that I have imported (including what was already in the contacts app) in the contacts app
* I am not expecting to see any markers to differentiate which contact was imported from which SIM.
Flags: in-moztrap?
Blocks: b2g-dsds-1.3
Hi folks,

this brings me some doubts about how to implement this.

- For example, should we show all the sim cards on the import window, but just the primary sim activated?
- Should our wording say something like change your sim to import?

Don't know if this is the corre user flow, maybe ux could should say something.

Also, do getcko backend knows about 'active' sim? Do we need to change something in our api call to the backend? Or the current api will always work against the active sym.

We also provide some information about when was the last import. Right now we don't count on having multiple sims, AFAIK, we dont deal with a sim id, so we will need to get that somehow to know when we imported the contacts from which sim.

Cheers,
F.
Whiteboard: [ucid:Comms36, 1.3:p1]
Based on what Sandip said in backlog Google document and also in the following Wiki: 
https://wiki.mozilla.org/B2G/Roadmap#Targeted_1.3_Features 
this one is a must have(committed) feature. Marked it "1.3+". 

Looks like it does not cover DSDS22. Sandip and/or Wilfred, do you prefer to use the same user story to track DSDS20 and DSDS22 both? 

DSDS22: "As I user, I should be able to see all contacts (from all subscriptions) listed together and can be edited for any entry (no indication of which SIM)."
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(wmathanaraj)
Flags: needinfo?(skamat)
Whiteboard: [ucid:Comms36, 1.3:p1] → [ucid:Comms36, ucid:DSDS20, 1.3:p1]
DSDS22 should be a acceptance criteria for this user story  - not a user story by itself. Hence why i have included the acceptance criteria above.
Flags: needinfo?(wmathanaraj)
Depends on: 814637
Flags: in-moztrap? → in-moztrap?(echu)
Hi,

Just updating this User Story after our latest sync meeting:

Description:
As I user, I should be able to import contacts from each SIM at a time


Acceptance Criteria:
* I am able to import contacts from each SIM at a time from Contacts->Settings
* I am not able to import contacts from an unavailable SIM:
** In case there is no SIM or SIM is locked, contacts import from that specific SIM will appear as “greyed out”
* I should be able to see all contacts that I have imported (from all subscriptions) listed together (including what were already in the contacts app) and can be edited
* I am not expecting to see any markers to differentiate which contact was imported from which SIM (subscription)
Summary: [User Story] [DSDS] Import contacts from current primary SIM → [User Story] [DSDS] Import contacts from from each SIM at a time
Summary: [User Story] [DSDS] Import contacts from from each SIM at a time → [User Story] [DSDS] Import contacts from each SIM at a time
Depends on: 928325
Whiteboard: [ucid:Comms36, ucid:DSDS20, 1.3:p1] → [ucid:Comms36, ucid:DSDS20, ucid:DSDS22, 1.3:p1]
Duplicate of this bug: 921968
Whiteboard: [ucid:Comms36, ucid:DSDS20, ucid:DSDS22, 1.3:p1] → [ucid:Comms36, ucid:DSDS20, ucid:DSDS22, 1.3:p1, FT:RIL]
Assignee: nobody → francisco.jordano
Target Milestone: --- → 1.3 Sprint 5 - 11/22
(In reply to Wilfred Mathanaraj [:WDM] from comment #3)
> DSDS22 should be a acceptance criteria for this user story  - not a user
> story by itself. Hence why i have included the acceptance criteria above.

Agree. However since DSDS22 is agreed with several parties, I will leave it in the Google doc for now as discussed on emails.
Flags: needinfo?(skamat)
Blocks: 937014
Remove blocking-b2g flag from User Story bugs. Use whiteboard to indicate what FxOS version we target.
blocking-b2g: 1.3+ → ---
add moztrap link.
Flags: in-moztrap?(echu) → in-moztrap+
Whiteboard: [ucid:Comms36, ucid:DSDS20, ucid:DSDS22, 1.3:p1, FT:RIL] → [ucid:Comms36, ucid:DSDS20, ucid:DSDS22, 1.3:p1, FT:comms]
Depends on: 940913
Target Milestone: 1.3 Sprint 5 - 11/22 → 1.3 Sprint 6 - 12/6
Whiteboard: [ucid:Comms36, ucid:DSDS20, ucid:DSDS22, 1.3:p1, FT:comms] → [ucid:Comms36, ucid:DSDS20, 1.3:p1, FT:comms]
Blocks: b2g-dsds-1.4
No longer blocks: b2g-dsds-1.4
Blocks: 939934
blocking-b2g: --- → 1.3+
Resolved in bug 940913
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Tested on Fugu
Gaia:     f64d282b6b44eaaf8cddc8be8f3250cb6fbacd95
Gecko:    0e3362fb5625eb6d98c7617b1b3019a2cc553d47
BuildID   20131202094818
Version   28.0a1

Link to bugs blocking or found during the test.
Depends on: 938422, 926351, 944572
No longer depends on: 938422, 944572, 926351
See Also: → 926351, 938422, 944572
See Also: 926351
Verified on 
Fugu
Gaia      ee25b0e45649d2955f340ce4f71ad55712dd0fab
Gecko     913cf2b92845441c9578787362ddad6f2ac15df6
BuildID   20140121095108
Version   28.0a2

No blocking AC bugs found, set status to Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.