Closed Bug 923653 Opened 7 years ago Closed 6 years ago

Layout of support contacts in settings is not displayed properly

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+, b2g-v1.2 verified)

VERIFIED FIXED
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- verified

People

(Reporter: albert, Assigned: lchang)

References

Details

Attachments

(3 files)

Attached image screenshot
Firefox os v1.2 & master (unagi)
 
DEFECT DESCRIPTION:
 Wrong layout of settings support contacts.
 
REPRODUCING PROCEDURES:
 1. flash gaia with single variant resources (support contacts) in distribution dir.
 2. go to settings -> help
 
See attached screenshot
Blocks: 891724
blocking-b2g: --- → koi?
Whiteboard: [systemsfe]
Can you provide test data you used to reproduce this bug?
blocking-b2g: koi? → koi+
Ended up seeing this bug while testing my reference customization, so that can be used to reproduce this bug as well:

https://github.com/mozilla/qa-testcase-data/tree/gh-pages/customization/reference
I can reproduce this bug.
But we need more information from UX team about how to fix its layout when the strings are too long.
Flags: needinfo?(nhsieh)
Please show that wording in next line. 

Call support:
+886 2 XXXX-XXXX
+886 2 XXXX-XXXX
Flags: needinfo?(nhsieh)
Luke, since you already lay your hand on this bug, do you have bandwidth to do it?
Assignee: nobody → lchang
Whiteboard: [systemsfe]
After discussing with UX team, we will change its design as the attachment.
Attached file pull request (12929)
Arther, Could you please help review this simple patch? Thanks.
Attachment #818820 - Flags: review?(achen)
Comment on attachment 818820 [details]
pull request (12929)

Reassign to bugzilla mail.
Attachment #818820 - Flags: review?(achen) → review?(arthur.chen)
Comment on attachment 818820 [details]
pull request (12929)

Cancel per offline discussion. Please help define the format of support.json and make corresponding changes in the code and wiki, thanks!
Attachment #818820 - Flags: review?(arthur.chen)
Duplicate of this bug: 930800
Comment on attachment 818820 [details]
pull request (12929)

Arthur, I've updated my patch and would like to ask you to review it again. Thanks.

For anyone else who may want to customize the support information, we have updated the format of "support.json" and you can find more details in the wiki. ( https://wiki.mozilla.org/B2G/MarketCustomizations#support )
Attachment #818820 - Flags: review?(arthur.chen)
Comment on attachment 818820 [details]
pull request (12929)

r=me. Thank you for the effort!
Attachment #818820 - Flags: review?(arthur.chen) → review+
travis passed:
https://travis-ci.org/mozilla-b2g/gaia/builds/13023059

merged in gaia master:
https://github.com/mozilla-b2g/gaia/commit/0535641471428fd4410c150881f3635326b0642f

Arthur, Thanks!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Keywords: verifyme
QA Contact: jsmith
Uplifted 0535641471428fd4410c150881f3635326b0642f to:
v1.2: ac0fdef9da4aeeefe18441867dd810dee96e0d79
Whiteboard: [systemfe]
Fixed!  on the following build
Gaia:     606517ceafe0950c2b89822d5f13353743334f2c
Gecko:    http://hg.mozilla.org/releases/mozilla-aurora/rev/5eabd267ef04
BuildID   20131025004000
Version   26.0a2
Status: RESOLVED → VERIFIED
Whiteboard: [systemfe] → [systemsfe]
Keywords: verifyme
QA Contact: jsmith
Whiteboard: [systemsfe]
You need to log in before you can comment on or make changes to this bug.