Perma-Orange TEST-UNEXPECTED-FAIL | tests/content/media/test/crashtests/874915.html | application timed out after 330 seconds with no output | [@ mozilla::dom::AudioChannelAgentCallback::CanPlayChanged(int)]

RESOLVED DUPLICATE of bug 874508

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 874508
4 years ago
4 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({crash})

Trunk
mozilla27
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
b2g_emulator_vm mozilla-inbound opt test crashtest-1 on 2013-10-04 05:09:28 PDT for push b607cc162c2c

slave: tst-linux64-ec2-324

https://tbpl.mozilla.org/php/getParsedLog.php?id=28741394&tree=Mozilla-Inbound

TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/content/media/test/crashtests/874915.html | application timed out after 330 seconds with no output
PROCESS-CRASH | http://10.0.2.2:8888/tests/content/media/test/crashtests/874915.html | application crashed [@ mozilla::dom::AudioChannelAgentCallback::CanPlayChanged(int)]

05:39:31     INFO -  checking for crashes in '/data/local/tests/profile/minidumps'
05:39:31  WARNING -  PROCESS-CRASH | http://10.0.2.2:8888/tests/content/media/test/crashtests/874915.html | application crashed [@ mozilla::dom::AudioChannelAgentCallback::CanPlayChanged(int)]
05:39:31     INFO -  Crash dump filename: /tmp/tmp2Zzrno/05857b4f-c8cc-8f9f-329e6721-61d59958.dmp
05:39:31     INFO -  Operating system: Android
05:39:31     INFO -                    0.0.0 Linux 2.6.29-00294-g701690d #1 Mon May 20 22:43:07 CST 2013 armv7l Android/full/generic:4.0.4.0.4.0.4/OPENMASTER/eng.cltbld.20131004.064049:eng/test-keys
05:39:31     INFO -  CPU: arm
05:39:31     INFO -       0 CPUs
05:39:31     INFO -  Crash reason:  SIGSEGV
05:39:31     INFO -  Crash address: 0x2c
05:39:31     INFO -  Thread 0 (crashed)
05:39:31     INFO -   0  libxul.so!mozilla::dom::AudioChannelAgentCallback::CanPlayChanged(int) [AudioDestinationNode.cpp:b607cc162c2c : 399 + 0xc]
05:39:31     INFO -       r4 = 0x461377c0    r5 = 0x40fd1e85    r6 = 0x46ab4dc0    r7 = 0x00000000
05:39:31     INFO -       r8 = 0x0000000c    r9 = 0x00000000   r10 = 0x410a865d    fp = 0x00000000
05:39:31     INFO -       sp = 0xbefc9520    lr = 0x410a83df    pc = 0x40fd1e92
05:39:31     INFO -      Found by: given as instruction pointer in context
05:39:31     INFO -   1  libxul.so!mozilla::dom::AudioChannelAgent::NotifyAudioChannelStateChanged() [AudioChannelAgent.cpp:b607cc162c2c : 158 + 0x17]
05:39:31     INFO -       r4 = 0x461377c0    r5 = 0x40fd1e85    r6 = 0x46ab4dc0    r7 = 0x00000000
05:39:31     INFO -       r8 = 0x0000000c    r9 = 0x00000000   r10 = 0x410a865d    fp = 0x00000000
05:39:31     INFO -       sp = 0xbefc9528    pc = 0x410a83df
05:39:31     INFO -      Found by: call frame info
05:39:31     INFO -   2  libxul.so!mozilla::dom::AudioChannelService::NotifyEnumerator(mozilla::dom::AudioChannelAgent*, mozilla::dom::AudioChannelService::AudioChannelAgentData*, void*) [AudioChannelService.cpp:b607cc162c2c : 520 + 0x5]
05:39:31     INFO -       r4 = 0x410a8631    r5 = 0x46cca840    r6 = 0x00000010    r7 = 0x00000000
05:39:31     INFO -       r8 = 0x0000000c    r9 = 0x00000000   r10 = 0x410a865d    fp = 0x00000000
05:39:31     INFO -       sp = 0xbefc9540    pc = 0x410a8639
05:39:31     INFO -      Found by: call frame info
05:39:31     INFO -   3  libxul.so!nsBaseHashtable<nsPtrHashKey<mozilla::dom::AudioChannelAgent>, nsAutoPtr<mozilla::dom::AudioChannelService::AudioChannelAgentData>, mozilla::dom::AudioChannelService::AudioChannelAgentData*>::s_EnumReadStub(PLDHashTable*, PLDHashEntryHdr*, unsigned int, void*) [nsBaseHashtable.h : 378 + 0x9]
05:39:31     INFO -       r4 = 0x410a8631    r5 = 0x46cca840    r6 = 0x00000010    r7 = 0x00000000
05:39:31     INFO -       r8 = 0x0000000c    r9 = 0x00000000   r10 = 0x410a865d    fp = 0x00000000
05:39:31     INFO -       sp = 0xbefc9548    pc = 0x410a8669
05:39:31     INFO -      Found by: call frame info
05:39:31     INFO -   4  libxul.so!PL_DHashTableEnumerate [pldhash.cpp:b607cc162c2c : 713 + 0x9]
05:39:31     INFO -       r4 = 0x46898030    r5 = 0x46cca840    r6 = 0x00000010    r7 = 0x00000000
05:39:31     INFO -       r8 = 0x0000000c    r9 = 0x00000000   r10 = 0x410a865d    fp = 0x00000000
05:39:31     INFO -       sp = 0xbefc9550    pc = 0x415b32e7
05:39:31     INFO -      Found by: call frame info
05:39:31     INFO -   5  libxul.so!mozilla::dom::AudioChannelService::Notify() [nsBaseHashtable.h : 173 + 0x3]
05:39:31     INFO -       r4 = 0x42276cb0    r5 = 0x00000000    r6 = 0x00000000    r7 = 0x00000000
05:39:31     INFO -       r8 = 0x00000000    r9 = 0x00000000   r10 = 0x00000000    fp = 0x00000000
05:39:31     INFO -       sp = 0xbefc9580    pc = 0x410a87bf
05:39:31     INFO -      Found by: call frame info
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 3

4 years ago
should be fixed with the backout from bug 874508
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Summary: Intermittent TEST-UNEXPECTED-FAIL | tests/content/media/test/crashtests/874915.html | application timed out after 330 seconds with no output | [@ mozilla::dom::AudioChannelAgentCallback::CanPlayChanged(int)] → Perma-Orange TEST-UNEXPECTED-FAIL | tests/content/media/test/crashtests/874915.html | application timed out after 330 seconds with no output | [@ mozilla::dom::AudioChannelAgentCallback::CanPlayChanged(int)]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Target Milestone: --- → mozilla27
Keywords: intermittent-failure
Resolution: FIXED → DUPLICATE
Duplicate of bug: 874508
You need to log in before you can comment on or make changes to this bug.