Closed Bug 92368 Opened 20 years ago Closed 13 years ago

when offline, viewing message in stand alone message window crashes

Categories

(SeaMonkey :: MailNews: Backend, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME
mozilla1.0.1

People

(Reporter: sspitzer, Assigned: hyatt)

References

Details

(Keywords: crash, Whiteboard: No reproducible case.)

Attachments

(1 file)

here's the stack.

happens on trunk, and on 0.9.2 branch (according to kmurray)

to reproduce, start in offline (check offline box in profile manager)
start mail, double click on a message.

nsCOMPtr<imgIRequest>::assign_assuming_AddRef(imgIRequest * 0x00000000) line 
471 + 3 bytes
nsCOMPtr<imgIRequest>::assign_with_AddRef(nsISupports * 0x00000000) line 964
nsCOMPtr<imgIRequest>::operator=(imgIRequest * 0x00000000) line 584
imgRequestProxy::Cancel(imgRequestProxy * const 0x05d304a0, unsigned int 
0x80004005) line 172
nsImageBoxFrame::UpdateImage(nsIPresContext * 0x04e38a90, int & 0x00000000) 
line 280
nsImageBoxFrame::DidSetStyleContext(nsImageBoxFrame * const 0x0534f0dc, 
nsIPresContext * 0x04e38a90) line 403
nsFrame::SetStyleContext(nsFrame * const 0x0534f0dc, nsIPresContext * 
0x04e38a90, nsIStyleContext * 0x053511f0) line 502
FrameManager::ReResolveStyleContext(nsIPresContext * 0x04e38a90, nsIFrame * 
0x0534f0dc, nsIStyleContext * 0x05350e38, nsIContent * 0x05c43380, int 
0x00000000, nsIAtom * 0x00000000, nsStyleChangeList & {...}, int 0x00000005, 
int & 0x0012bd74) line 1693
FrameManager::ReResolveStyleContext(nsIPresContext * 0x04e38a90, nsIFrame * 
0x0534f02c, nsIStyleContext * 0x0534c394, nsIContent * 0x00000000, int 
0x00000000, nsIAtom * 0x024dbe80, nsStyleChangeList & {...}, int 0x00000005, 
int & 0x00000005) line 1837
FrameManager::ComputeStyleChangeFor(FrameManager * const 0x04e4ba50, 
nsIPresContext * 0x04e38a90, nsIFrame * 0x0534f02c, int 0x00000000, nsIAtom * 
0x024dbe80, nsStyleChangeList & {...}, int 0x00000003, int & 0x00000000) line 
2082
nsCSSFrameConstructor::AttributeChanged(nsCSSFrameConstructor * const 
0x04e4c7f0, nsIPresContext * 0x04e38a90, nsIContent * 0x05c43380, int 
0x00000000, nsIAtom * 0x024dbe80, int 0x00000003) line 10050
StyleSetImpl::AttributeChanged(StyleSetImpl * const 0x04e49c50, nsIPresContext 
* 0x04e38a90, nsIContent * 0x05c43380, int 0x00000000, nsIAtom * 0x024dbe80, 
int 0xffffffff) line 1204
PresShell::AttributeChanged(PresShell * const 0x04e4dd38, nsIDocument * 
0x05a25770, nsIContent * 0x05c43380, int 0x00000000, nsIAtom * 0x024dbe80, int 
0xffffffff) line 4941 + 57 bytes
nsXULDocument::AttributeChanged(nsXULDocument * const 0x05a25770, nsIContent * 
0x05c43380, int 0x00000000, nsIAtom * 0x024dbe80, int 0xffffffff) line 1634
nsXULElement::SetAttribute(nsXULElement * const 0x05c43380, nsINodeInfo * 
0x04e6e690, const nsAString & {...}, int 0x00000001) line 3047
nsXULElement::SetAttribute(nsXULElement * const 0x05c43384, const nsAString & 
{...}, const nsAString & {...}) line 1394 + 31 bytes
nsXULElement::SetAttribute(nsXULElement * const 0x05c1f5b0, nsINodeInfo * 
0x04e6e690, const nsAString & {...}, int 0x00000001) line 2998
nsXULElement::SetAttribute(nsXULElement * const 0x05c1f5b4, const nsAString & 
{...}, const nsAString & {...}) line 1394 + 31 bytes
XPTC_InvokeByIndex(nsISupports * 0x05c1f5b4, unsigned int 0x0000001e, unsigned 
int 0x00000002, nsXPTCVariant * 0x0012c8f4) line 139
XPCWrappedNative::CallMethod(XPCCallContext & {...}, XPCWrappedNative::CallMode 
CALL_METHOD) line 1882 + 42 bytes
XPC_WN_CallMethod(JSContext * 0x059fc180, JSObject * 0x0532a008, unsigned int 
0x00000002, long * 0x0535b1e0, long * 0x0012cb28) line 1252 + 11 bytes
js_Invoke(JSContext * 0x059fc180, unsigned int 0x00000002, unsigned int 
0x00000000) line 807 + 23 bytes
js_Interpret(JSContext * 0x059fc180, long * 0x0012d8c8) line 2697 + 15 bytes
js_Invoke(JSContext * 0x059fc180, unsigned int 0x00000001, unsigned int 
0x00000002) line 824 + 13 bytes
nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJSClass * const 0x02eefb50, 
nsXPCWrappedJS * 0x05ac9ee0, unsigned short 0x0003, const nsXPTMethodInfo * 
0x00d30ce0, nsXPTCMiniVariant * 0x0012de0c) line 1019 + 21 bytes
nsXPCWrappedJS::CallMethod(nsXPCWrappedJS * const 0x05ac9ee0, unsigned short 
0x0003, const nsXPTMethodInfo * 0x00d30ce0, nsXPTCMiniVariant * 0x0012de0c) 
line 427
PrepareAndDispatch(nsXPTCStubBase * 0x05ac9ee0, unsigned int 0x00000003, 
unsigned int * 0x0012debc, unsigned int * 0x0012deac) line 100 + 31 bytes
SharedStub() line 124
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x05ac9f40, 
nsIDOMEvent * 0x05d70504, nsIDOMEventTarget * 0x059fc340, unsigned int 
0x00000001, unsigned int 0x00000004) line 1161 + 20 bytes
nsEventListenerManager::HandleEvent(nsEventListenerManager * const 0x05a568b0, 
nsIPresContext * 0x05d45640, nsEvent * 0x0012f0cc, nsIDOMEvent * * 0x0012f084, 
nsIDOMEventTarget * 0x059fc340, unsigned int 0x00000004, nsEventStatus * 
0x0012f0f4) line 1834 + 36 bytes
GlobalWindowImpl::HandleDOMEvent(GlobalWindowImpl * const 0x059fc330, 
nsIPresContext * 0x05d45640, nsEvent * 0x0012f0cc, nsIDOMEvent * * 0x0012f084, 
unsigned int 0x00000004, nsEventStatus * 0x0012f0f4) line 598
nsXULDocument::HandleDOMEvent(nsXULDocument * const 0x05a25770, nsIPresContext 
* 0x05d45640, nsEvent * 0x0012f0cc, nsIDOMEvent * * 0x0012f084, unsigned int 
0x00000004, nsEventStatus * 0x0012f0f4) line 2007
nsXULElement::HandleDOMEvent(nsXULElement * const 0x05a56910, nsIPresContext * 
0x05d45640, nsEvent * 0x0012f0cc, nsIDOMEvent * * 0x0012f084, unsigned int 
0x00000004, nsEventStatus * 0x0012f0f4) line 3605 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x05ac53c0, nsIPresContext * 
0x05d45640, nsEvent * 0x0012f0cc, nsIDOMEvent * * 0x0012f084, unsigned int 
0x00000004, nsEventStatus * 0x0012f0f4) line 3603
nsXULElement::HandleDOMEvent(nsXULElement * const 0x05ac51b0, nsIPresContext * 
0x05d45640, nsEvent * 0x0012f0cc, nsIDOMEvent * * 0x0012f084, unsigned int 
0x00000004, nsEventStatus * 0x0012f0f4) line 3603
nsXULElement::HandleChromeEvent(nsXULElement * const 0x05ac51c0, nsIPresContext 
* 0x05d45640, nsEvent * 0x0012f0cc, nsIDOMEvent * * 0x0012f084, unsigned int 
0x00000004, nsEventStatus * 0x0012f0f4) line 4594 + 39 bytes
GlobalWindowImpl::HandleDOMEvent(GlobalWindowImpl * const 0x05d3d490, 
nsIPresContext * 0x05d45640, nsEvent * 0x0012f0cc, nsIDOMEvent * * 0x0012f084, 
unsigned int 0x00000001, nsEventStatus * 0x0012f0f4) line 594
DocumentViewerImpl::LoadComplete(DocumentViewerImpl * const 0x05d3c4f0, 
unsigned int 0x00000000) line 1101 + 47 bytes
nsDocShell::EndPageLoad(nsIWebProgress * 0x05d381c4, nsIChannel * 0x05d39930, 
unsigned int 0x00000000) line 3743
nsWebShell::EndPageLoad(nsIWebProgress * 0x05d381c4, nsIChannel * 0x05d39930, 
unsigned int 0x00000000) line 894
nsDocShell::OnStateChange(nsDocShell * const 0x05d38b24, nsIWebProgress * 
0x05d381c4, nsIRequest * 0x05d39930, int 0x00020010, unsigned int 0x00000000) 
line 3664
nsDocLoaderImpl::FireOnStateChange(nsIWebProgress * 0x05d381c4, nsIRequest * 
0x05d39930, int 0x00020010, unsigned int 0x00000000) line 1095
nsDocLoaderImpl::doStopDocumentLoad(nsIRequest * 0x05d39930, unsigned int 
0x00000000) line 734
nsDocLoaderImpl::DocLoaderIsEmpty() line 632
nsDocLoaderImpl::OnStopRequest(nsDocLoaderImpl * const 0x05d381b4, nsIRequest * 
0x05d39930, nsISupports * 0x00000000, unsigned int 0x00000000) line 563
nsLoadGroup::RemoveRequest(nsLoadGroup * const 0x05d38140, nsIRequest * 
0x05d39930, nsISupports * 0x00000000, unsigned int 0x00000000) line 512 + 44 
bytes
nsStreamIOChannel::OnStopRequest(nsStreamIOChannel * const 0x05d39934, 
nsIRequest * 0x05d39824, nsISupports * 0x00000000, unsigned int 0x00000000) 
line 466
nsOnStopRequestEvent::HandleEvent() line 161
nsARequestObserverEvent::HandlePLEvent(PLEvent * 0x05d39404) line 64
PL_HandleEvent(PLEvent * 0x05d39404) line 590 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00e85900) line 520 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x0048023e, unsigned int 0x0000c0e2, unsigned 
int 0x00000000, long 0x00e85900) line 1071 + 9 bytes
USER32! 77e13eb0()
USER32! 77e1401a()
USER32! 77e192da()
nsAppShellService::Run(nsAppShellService * const 0x00566b30) line 425
main1(int 0x00000002, char * * 0x00484190, nsISupports * 0x00000000) line 1290 
+ 32 bytes
main(int 0x00000002, char * * 0x00484190) line 1599 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e87903()
I suspect this has to do with the particular message you're trying to display
while offline. I tried this for a bunch of messages and had no problem. Is that
true, Seth? Is it every message or a particular one?
possibly related to bug 87923

my talkback id TB33348145Q. Crashed for when I clicked on
the embeded netscape home page.

good catch gchan. This does indeed look like a dup as David B. crashes in the
same image request code in that bug. We should mark this a dup of 87923.
if it's the same bug, that would explain why I can't recreate either of them :-(
This was the windows error message that popped up when I crashed
2nd time (this time I did not click a message with a web page embedded in it)
but it eventually crashed about the 6th message. Maybe unstable due to
my earlier crash when I did click on a embedded message?

The windows error mesg:
 The exception Single Step
 A single step or trace operation has just been completed
 (0x80000004) occurred in application at loaction 0x04a08555.

one more talkback id TB33348501Z
http://climate.mcom.com/reports/incidenttemplate.cfm?bbid=33348501
Ok Based on David and Mscott's comments going to mark
this as dupe of bug 87923

*** This bug has been marked as a duplicate of 87923 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
sorry one more note. This was planning on being release noted. I'll probably
send off one more draft to the offline people for review tommorrow.
Let me know if you want to be includeed.
I found that I could not reproduce this if I changed my cache settings from
"automatic" to "every time I view the page". Something about that changed the
timing/asynchronicity of the img reqeusts and prevented the crash. I'm reopening
this because this bug is so much easier to reproduce than the other dup.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Some more observations.

It occurs on linux and windows. I couldn't get this to
crash on MAC.

It only happens if you start messenger/browser in
offline mode (either by checking work offline in the profile
manager or if the pref 'remember my prev mode' was fixed [see bug 82487]
would be the only other way)

Doesn't matter if you double click a downloaded or non-downloaded
message as they both will crash.

If you start online then go offline, I could not make it crash
when I double clicked on a message.

I don't think a web page embedded in a mail message makes a difference.
Just my opinion as I was able to crash on normal text message. Maybe
it makes it easier to crash?
David owns the offline fun.
Assignee: sspitzer → bienvenu
Status: REOPENED → NEW
reassigning to Pav. 
Assignee: bienvenu → pavlov
Keywords: nsenterprise
with this morning's build, this now works for me.  If anyone else wants to try
it and let me know if they see it or not, perhaps we can resolve this.
Commercial trunk builds
2001082403 - win nt 4.0

Still seeing this error David. Though I think it has changed 
slightly. 

-Works fine, if you start online, then go offline, and
 double clicking a downloaded/non-downloaded message
 (tried all types: text, html, gif/jpeg attachs, html attach,
  embeded web pages,etc..)
-Works fine, if you start profile mgr, check the work offline
 box, start messenger, double clicking any NON-downloaded
 message (text, html, gif/jpeg attachs, html attach, embeded web pages,etc..)

-Will Crash: if you start profile mgr, check the work offline
 box, start messenger, double click on a downloaded mesg that
 has a web page embeded in it. Does not crash on attachments, reg
 mail, etc.. Only with a mail message that was sent using File|Send
 Page. The message crashed with embeded netscape's home page.


I think the stack trace is different now. Can't confirm my earlier
stacks traces as they have been purged from talkback. It differs
from Kevin's and Stephen's stack traces.

Talkback Ids TB34476926E, TB34476538K

Stack trace:
0x052f8ecf 

nsImageBoxFrame::DidSetStyleContext 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsImageBoxFrame.cpp, line 388]
    
nsFrame::SetStyleContext 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrame.cpp, line 504]
     
FrameManager::ReResolveStyleContext 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1695]
     
FrameManager::ReResolveStyleContext 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1839]
     
FrameManager::ReResolveStyleContext 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1839]
     
FrameManager::ComputeStyleChangeFor 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 2086]
     
nsCSSFrameConstructor::AttributeChanged 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 10189]
     
StyleSetImpl::AttributeChanged 
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1228]
     
PresShell::AttributeChanged 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4952]
     
nsXULDocument::AttributeChanged 
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 
1741]
     
nsXULElement::SetAttr 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3091]
     
nsXULElement::SetAttribute 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
1434]
     
nsXULElement::SetAttr 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3041]
     
nsXULElement::SetAttribute 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
1434]
     
XPTC_InvokeByIndex 
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp, 
line 139]
     
XPCWrappedNative::CallMethod 
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 
1886]
     
XPC_WN_CallMethod 
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp, 
line 1253]
     
js_Invoke 
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 809]
     
js_Interpret 
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2698]
     
js_Invoke 
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 825]
     
nsXPCWrappedJSClass::CallMethod 
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjsclass.cpp, line 
1025]
     
nsXPCWrappedJS::CallMethod 
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjs.cpp, line 427]
     
PrepareAndDispatch 
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp, 
line 102]
     
SharedStub 
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp, 
line 124]
     
nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line 
1197]
     
nsEventListenerManager::HandleEvent 
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line 
1872]
     
GlobalWindowImpl::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 599]
     
nsXULDocument::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 
2114]
     
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3696]
     
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3689]
     
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3689]
     
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3689]
     
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3689]
     
nsXULElement::HandleChromeEvent 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
5009]
     
GlobalWindowImpl::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 595]
     
DocumentViewerImpl::LoadComplete 
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 1094]
     
nsDocShell::EndPageLoad 
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 3725]
     
nsWebShell::EndPageLoad 
[d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, line 893]
     
nsDocShell::OnStateChange 
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 3646]
     
nsDocLoaderImpl::FireOnStateChange 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 1095]
     
nsDocLoaderImpl::doStopDocumentLoad 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 734]
     
nsDocLoaderImpl::DocLoaderIsEmpty 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 632]
     
nsDocLoaderImpl::OnStopRequest 
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 563]
     
nsLoadGroup::RemoveRequest 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsLoadGroup.cpp, line 517]
     
nsStreamIOChannel::OnStopRequest 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsInputStreamChannel.cpp, line 
466]
     
nsOnStopRequestEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 
162]
     
PL_HandleEvent 
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
     
PL_ProcessPendingEvents 
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 524]
     
_md_EventReceiverProc 
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 1072]
it used to crash on any message, even one you hadn't downloaded for offline use,
trying to fetch the offline icon/widget, so I think it's a different kind of
bug, though still probably in Pav's area.
agreed. it now only crashes if it's downloaded and has an embeded
web page in it. hmm guess some other fixes indirectly are fixing
this bug. I haven't tested 87923 to see what the results
are for that yet..
nsenterprise+ bugs are supposed to be in the .9.4 milestone. making that adjustment.
Target Milestone: --- → mozilla0.9.4
Adding crash keyword.
Keywords: crash
*** Bug 95626 has been marked as a duplicate of this bug. ***
Changing based on dupes.
Severity: normal → critical
OS: Windows 2000 → All
Hardware: PC → All
If indeed 95626 is a duplicate of this bug, then I'll add my observations here:
The _second_ time I run Mozilla, it will crash the first time I try to retrieve
mail.  This is under Solaris using movemail - does offline apply to movemail?
In addition, the content of the message makes no difference, it is an
equal-opportunity crasher.

I put a stack trace into my report under 95626.
0.9.4 is out the door
Target Milestone: mozilla0.9.4 → mozilla0.9.5
Keywords: nsbranch+
Status: NEW → ASSIGNED
Priority: -- → P2
Can we get some traction on this?  this is a stop ship for enterprise customers.
 Thanks.
I'm working on this...
Whiteboard: PDT
Whiteboard: PDT → [PDT], [ETA ?]
I can't reproduce this.  Is this still happening for anyone else?
Hey Pav.
I can still reproduce the bug. Kind of tricky.
I was using 2001-09-26-05-0.9.4 commercial branch on nt 4.0

It only crashed for me with a embedded Netscape web page.
I tried Cnn and Cnet and it did not crash. My mail
message with the Netscape web page is from 7-30-2001.

steps.
1.make sure you downloaded couple of mail messages (some plain,
  some with web pages) for offline use already.
2.start profile mgr
3.select the profile with downloaded imap mail mesgs
4.check the work offlie checkbox in profile mgr
5.start browser
6.start messenger
7.Double click few of downloaded mesgs so it opens it up
  in a new window
8.Double click on downloaded mesg with Netscape home page.

result: crash

The stack trace is pretty much the same as Kevin's original
stack trace at the top of this bug.

My talk back id's are as follows
 TB35930992Z,TB35931199E,TB35931361W

Stack trace as follows:
  
0x56295bbd  
nsCOMPtr_base::assign_with_AddRef 
   [d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 59]   
nsRuleNode::GetStyleData 
   [d:\builds\seamonkey\mozilla\content\html\style\src\nsRuleNode.cpp, line 
   4600] 
nsStyleContext::GetStyleData 
    [d:\builds\seamonkey\mozilla\content\base\src\nsStyleContext.cpp, line 370]   
nsImageBoxFrame::DidSetStyleContext 
   [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsImageBoxFrame.cpp, line 
   390]     
nsImageBoxFrame::DidSetStyleContext 
  [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsImageBoxFrame.cpp, line 
   390]
nsFrame::SetStyleContext 
 [d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrame.cpp, line 504] 
FrameManager::ReResolveStyleContext 
 [d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 
1695]
FrameManager::ReResolveStyleContext 
 [d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line  
 1839]
FrameManager::ReResolveStyleContext 
  [d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 
 1839]
FrameManager::ComputeStyleChangeFor 
  [d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 
 2086]
nsCSSFrameConstructor::AttributeChanged 
   [d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
  line 10230]
StyleSetImpl::AttributeChanged 
 [d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1230]
PresShell::AttributeChanged 
  [d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5008]
nsXULDocument::AttributeChanged 
   [d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 
   1742]
nsXULElement::SetAttr 
   [d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
   3094]
nsXULElement::SetAttribute 
 [d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
  1434]
nsXULElement::SetAttr 
  [d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
   3041]
nsXULElement::SetAttribute 
   [d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
    1434]
XPTC_InvokeByIndex 
  
 [d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp, 
 line 139]
XPCWrappedNative::CallMethod 
 [d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 
 1954]
XPC_WN_CallMethod 
  [d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp, 
 line 1263]
js_Invoke 
  [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 809]
js_Interpret 
 [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2720]
js_Invoke 
   [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 825]
nsXPCWrappedJSClass::CallMethod 
 [d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjsclass.cpp, line 
  1024]
nsXPCWrappedJS::CallMethod 
 [d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjs.cpp, line 430]
PrepareAndDispatch 
  [d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp, 
  line 102]
SharedStub 
 [d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp, 
  line 124]
nsEventListenerManager::HandleEventSubType
  [d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, 
  line 1197]
nsEventListenerManager::HandleEvent 
  [d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, 
  line 1872]
GlobalWindowImpl::HandleDOMEvent 
  [d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 604]
nsXULDocument::HandleDOMEvent 
 [d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 
  2115]
nsXULElement::HandleDOMEvent 
 [d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
  3699]
nsXULElement::HandleDOMEvent 
 [d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
  3692]
nsXULElement::HandleDOMEvent 
 [d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
  3692]
nsXULElement::HandleDOMEvent 
 [d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
  3692]
nsXULElement::HandleDOMEvent 
 [d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
  3692]
nsXULElement::HandleChromeEvent 
  [d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
  5024]
GlobalWindowImpl::HandleDOMEvent 
  [d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 600]
DocumentViewerImpl::LoadComplete 
 [d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 1096]
nsDocShell::EndPageLoad 
 [d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 3730]
nsWebShell::EndPageLoad 
  [d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, line 898]
nsDocShell::OnStateChange 
 [d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 3651]
nsDocLoaderImpl::FireOnStateChange 
 [d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 1095]
nsDocLoaderImpl::doStopDocumentLoad 
 [d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 734]
nsDocLoaderImpl::DocLoaderIsEmpty 
 [d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 632]
nsDocLoaderImpl::OnStopRequest 
 [d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 563]
nsLoadGroup::RemoveRequest 
  [d:\builds\seamonkey\mozilla\netwerk\base\src\nsLoadGroup.cpp, line 521]
nsStreamIOChannel::OnStopRequest 
  [d:\builds\seamonkey\mozilla\netwerk\base\src\nsInputStreamChannel.cpp, line 
  466]
nsOnStopRequestEvent::HandleEvent 
   [d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, 
   line 162]
PL_HandleEvent 
  [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents 
 [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 524]
_md_EventReceiverProc 

Oops forgot to mention I was physically disconnected from
the network before I started step 2.

And I can only crash with the web page captured from July 30,2001.
I tried today's home page and could not reproduce the problem.

Pav, I'll forw you the mail mesg that I am crashing on.
crash is in CSS, that is in hyatt-code.  ccing him.  The original crash I had
already fixed was the same cause of 87923.
-> hyatt
Assignee: pavlov → hyatt
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9.5 → mozilla1.0
nsbranch-, this is so difficult to reproduce that it may not affect any actual
users, we don't have a fix, and it is too late to be taking risks for such low
benefit.
Keywords: nsbranch+nsbranch-
Taking off nsenterprise radar.
Removing [PDT] grafitti because this was minused by component team.
Whiteboard: [PDT], [ETA ?]
Blocks: 107067
Keywords: nsbranch-
Can anyone reproduce this in existing pages, with recent builds?
Whiteboard: No reproducible case.
Sort of..

Using 2001-10-26-09-trunk/ on NT 4.0

I cannot generate the same stack trace anymore. 
In my comments to Pav on 2001-09-26 18:43, I mentioned
I crashed using Netscape's 7/30 home page. Well using
the same page now, I crash, but the stack trace is totally
different. 

I've also generated a slightly different crash using today's (10-30) Cnet home
page. It's pretty close to my Netscape page crash as they both
involve nsRuleNode.cpp.

Also in both cases: a error dialog pops up now (it didn't before)
it says: "this page can't be edited for an unknown reason"
before it crashes.

I'm not sure what we want to do with this bug: create new one,
fix bugs I found in this one, etc..

In order to reproduce you need to do following:
 -do a 'send page' and mail it to yourself
 -download that mesg with the web page in it
 -start up in offline mode (using profile mgr)
 -select the mesg
 -do a reply or reply all to see crash

First stack trace using netscape's 7/30 web page (first few lines only)
TB Ids: 37405942,37406372

Call Stack:    (Signature = nsStyleContext::SetStyle f0c85c00) 

nsStyleContext::SetStyle 
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleContext.cpp, line 505]

nsRuleNode::WalkRuleTree 
[d:\builds\seamonkey\mozilla\content\base\src\nsRuleNode.cpp, line 1449]

nsRuleNode::GetBackgroundData 
[d:\builds\seamonkey\mozilla\content\base\src\nsRuleNode.cpp, line 1196]

nsRuleNode::GetStyleData 
[d:\builds\seamonkey\mozilla\content\base\src\nsRuleNode.cpp, line 4294]

nsStyleContext::GetStyleData 
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleContext.cpp, line 380]

----------------------

2nd stack trace w/crash off cnet home page (first few lines only)
TB ids: 37405651,37407399,37407587
Call Stack:    (Signature = nsRuleNode::ComputeBackgroundData 4961ccf4)

nsRuleNode::ComputeBackgroundData
[d:\builds\seamonkey\mozilla\content\base\src\nsRuleNode.cpp, line 2944]

nsRuleNode::WalkRuleTree
[d:\builds\seamonkey\mozilla\content\base\src\nsRuleNode.cpp, line 1458]

nsRuleNode::GetBackgroundData
[d:\builds\seamonkey\mozilla\content\base\src\nsRuleNode.cpp, line 1196]

nsRuleNode::GetStyleData
[d:\builds\seamonkey\mozilla\content\base\src\nsRuleNode.cpp, line 4294]

nsStyleContext::GetStyleData
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleContext.cpp, line 380]

nsRuleNode::ComputeBackgroundData
[d:\builds\seamonkey\mozilla\content\base\src\nsRuleNode.cpp, line 2915]

 
Oop should be clearer in steps to reproduce:
-Be physically disconnected from the network before starting browser
 and replying to downloaded mesgs
-when I say start up in offline mode (do not start in online mode
 then go offline, you must first start in offline mode by using
 profile mgr and click the work offline check box)
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1
No longer blocks: 107067
Blocks: 156187
Product: Browser → Seamonkey
(In reply to comment #35)
> Oop should be clearer in steps to reproduce:
> -Be physically disconnected from the network before starting browser
>  and replying to downloaded mesgs
> -when I say start up in offline mode (do not start in online mode
>  then go offline, you must first start in offline mode by using
>  profile mgr and click the work offline check box)

can you still create the crash?
WFM : Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007090302 SeaMonkey/2.0a1pre
Status: ASSIGNED → RESOLVED
Closed: 20 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.