Closed Bug 923714 Opened 6 years ago Closed 6 years ago

[B2G] E.me] Customized apps placed on the dock area pixelated

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 915145

People

(Reporter: dsubramanian, Unassigned)

Details

(Whiteboard: [e.me 1.2 test run])

Attachments

(1 file)

Description:
When customized collection of apps are placed on the dock area, the user sees that icons are pixelated.

Repro Steps:
1) Updated Buri Build ID: 20131004040203.
2) Tap on the search field.
3) Add a search word (eg: Jewelry, Electronics or Archeologist).
4) Long hold on the star icon on the landing page (found on the right hand-side below the search field).
5) On the banner option, select "Add to Collection".
6) Customize the collection.
7) Find the customized app on the Homescreen.
8) Move to the dock area.
9) Observe the dock area along with the other system/native apps.


Actual:
System/Native App icons and customized icons are pixelated.

Expected:
System/Native App icons and customized icons are NOT pixelated.

Environmental Variables
Build ID: 20131004040203
Gecko: http://hg.mozilla.org/mozilla-central/rev/8f08240128c8
Gaia: 1ac6749e36424124493a1b4c7534f298789bdffd
Platform Version: 27.0a1

Notes:
Repro frequency: 100%
Attached Screenshot. (Please zoom in to see screenshot of this defect)
Blocks: 1.3-e.me
Question before I nominate this to Ran:

Ran - Why are we getting pixelated icons here? Is this the fault of the site underlying the e.me app? Or is this a problem in the collections implementation?

If it's a bug on e.me collections side, then this likely needs to block the release, as the homescreen needs to have a solid UX to ship. Will wait for Ran's input before considering to nom.
Flags: needinfo?(ran)
Do you guys mean the dock icon misalignment? (using the term "pixelated" here confuses me)
Flags: needinfo?(ran)
(In reply to Ran Ben Aharon (Everything.me) from comment #2)
> Do you guys mean the dock icon misalignment? (using the term "pixelated"
> here confuses me)

Not the misalignment, even though the screenshot references it. This is talking about the image quality seen with the icons within the collection (e.g. best buy icon, amazon icon, youtube icon).
This is a actually a Gecko issue (changing to Gecko 18 resolves the bug)
It is reported in Bug 915145.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 915145
No longer blocks: 1.3-e.me
You need to log in before you can comment on or make changes to this bug.