Closed Bug 923739 Opened 8 years ago Closed 8 years ago

[Messages] Words that are separated by a period are treated as Browser links regardless of content

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ckreinbring, Assigned: rwaldron)

Details

(Whiteboard: burirun2)

Attachments

(2 files)

Description:
Sending an SMS with two words that are separated by a period will show the words underlined and will attempt to load a Browser page when selected.

Repro Steps:
1) Update Buri to Build ID: 20131004004003
2) Send an SMS to the device containing two words separated by a period. (eg Testcase.fail)
3) Observe the appearance of the text when it appears.
4) Tap the text and observe the device's reaction.

Actual:
The text has an underline that appears when text can be tapped, and tapping it attempts to load a Browser page (which usually fails).

Expected:
The text appears as normal text, and tapping it does nothing.

Environmental Variables
Device: Buri 1.2 mozilla RIL
Build ID: 20131004004003
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/a4b7282df517
Gaia: 9e21b6bea92fdafcb6787120a8cde0eb25a50495
Platform Version: 26.0a2

Notes:
Repro frequency: 100%
Test Suite Name: SMS
UCID: messages-008
Link to failed test case: https://moztrap.mozilla.org/manage/cases/?filter-id=7187
See attached screenshot
blocking-b2g: --- → koi?
".xx", ".xxx", ".xxxx" are all valid domain TLD patterns, but it looks like other platforms are whitelisting because I can't repro on iOS7 

http://en.wikipedia.org/wiki/List_of_Internet_top-level_domains
Assignee: nobody → waldron.rick
Summary: [B2G] [SMS] Words that are separated by a period are treated as Browser links regardless of content → [Messages] Words that are separated by a period are treated as Browser links regardless of content
This isn't a regression, the app never special cased TLDs
- Transform strings to clickable links of they match the URL expression and the matched tld portion is a valid
- Valid tlds stored in whitelist array.
Attachment #813821 - Flags: review?(felash)
Attachment #813821 - Flags: feedback?(gnarf37)
Sounds like if it's not a regression it isn't a blocker. Although we might want to consider asking for approval on this.
blocking-b2g: koi? → ---
(In reply to Jason Smith [:jsmith] from comment #4)
> Sounds like if it's not a regression it isn't a blocker. Although we might
> want to consider asking for approval on this.

Agreed on both, as it's a pretty small change to improve the overall experience (as I'm sure people regularly mistype and omit the space after a period at the end of a sentence)
Comment on attachment 813821 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/12674

mostly good, but have some nits and questions on the PR
holding my r until we answer them
(In reply to Julien Wajsberg [:julienw] (in MozSummit until next monday) from comment #7)
> Comment on attachment 813821 [details] [review]
> https://github.com/mozilla-b2g/gaia/pull/12674
> 
> mostly good, but have some nits and questions on the PR
> holding my r until we answer them

Good catch, updated with fixes and tests for the "has http:" case
Comment on attachment 813821 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/12674

r=me with the nits fixed and provided Travis is green.
Attachment #813821 - Flags: review?(felash) → review+
Landed on master https://github.com/mozilla-b2g/gaia/commit/9876831a73f5d767b2063b3fdd6fd3578c35c01d
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.