First-time Publish/Claim-on-makes.org action impossible in Goggles

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: humph, Assigned: pomax)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Our UI for publishing with Goggles is suitable for the case that you've already claimed your domain on makes.org.  However, if you haven't, it's impossible to do from Goggles' publishing UI directly.

STR:

1) Make sure you are logged out of webmaker
2) Go to goggles.webmaker.org
3) Click "Active X-Ray Goggles" button in the page
4) Press 'p' to publish
5) Click sign-in, and use an email address you haven't used before
6) Try to claim your domain on makes.org

The UI is pushed off below the visible area in the publish header, and it's impossible to interact with on that page.
(Reporter)

Updated

5 years ago
Duplicate of this bug: 923797
(Assignee)

Comment 2

5 years ago
Screen from duplicate bug: https://bug923797.bugzilla.mozilla.org/attachment.cgi?id=813855

this looks like a fragment marker and CSS positioning issue. Taking.
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Assignee: nobody → pomax
(Assignee)

Updated

5 years ago
See Also: → bug 923777
(Assignee)

Comment 3

5 years ago
Created attachment 817316 [details] [review]
https://github.com/mozilla/goggles.webmaker.org/pull/45

Fix 1 of 2, other fix is in login.webmaker.org (without that fix, you will see multiple empty new-user dialogs getting created each time you try to sign in)
Attachment #817316 - Flags: review?(thomas.park)
(Assignee)

Comment 4

5 years ago
Created attachment 817320 [details] [review]
https://github.com/mozilla/login.webmaker.org/pull/186

part 2 of 2. Without this fix the login process will attach multiple empty new user dialogs each time you sign in.
Attachment #817320 - Flags: review?(thomas.park)
Attachment mime type: text/plain text/plain → text/x-github-pull-request text/x-github-pull-request

Updated

5 years ago
Attachment #817320 - Flags: review?(thomas.park) → review+
Part 2 looks good, one comment on part 1.

Updated

5 years ago
Attachment #817316 - Flags: review?(thomas.park) → review-
(Assignee)

Comment 6

5 years ago
Comment on attachment 817316 [details] [review]
https://github.com/mozilla/goggles.webmaker.org/pull/45

added the top:140px, looks much nicer, good catch.
Attachment #817316 - Flags: review- → review?(thomas.park)

Updated

5 years ago
Attachment #817316 - Flags: review?(thomas.park) → review+

Comment 7

5 years ago
Commit pushed to master at https://github.com/mozilla/login.webmaker.org

https://github.com/mozilla/login.webmaker.org/commit/85bce2330faf152497ee92d225fa5d7c1e78b5bc
Merge pull request #186 from Pomax/bug923758

edgecase bug causing the new-user form to add itself multiple times
(Assignee)

Comment 8

5 years ago
both parts landed
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.