charset in Content-Type causes <script src=""> to fail

RESOLVED WORKSFORME

Status

()

Core
DOM
P1
normal
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: jst)

Tracking

({testcase, topembed})

Trunk
x86
Windows 2000
testcase, topembed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
STEPS TO REPRODUCE
  Look at the attachment. It has a Content-Type meta tag:
     <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  ...and links to this external script:
     http://ad.uk.doubleclick.net/adj/homepage.av.monaco.fr/fullbanner;sz=468x60

ACTUAL RESULTS
  Browser spins, apparently blocked trying to download the script.

EXPECTED RESULTS
   IE6-pre renders the page fine.

This broke out of Bugscape bug number 7921.
(Reporter)

Comment 1

17 years ago
Created attachment 43635 [details]
Test case - page should display an advert and the word "PASS".
(Reporter)

Updated

17 years ago
Keywords: testcase
Priority: -- → P1
Hmmm.  Works fine for me on my Linux debug trunk build.  But assigning to DOM
Other component.  (Who owns META-charset reload issues?)
Assignee: clayton → jst
Component: HTML Element → DOM Other
QA Contact: bsharma → gerardok
(Reporter)

Comment 3

17 years ago
Maybe this is a 0.9.2ec-specific bug?
Keywords: topembed
(Assignee)

Comment 4

16 years ago
Hmm, works fine using a commercial Netscape 6.1 build, investigating...
(Assignee)

Comment 5

16 years ago
I've been trying to reproduce this with a branch build for a few days now, tried
everything I could think of but I'm unable to reproduce the problem, it always
works for me.

Marking WORKSFORME, please reopen and tell me how to reproduce this if this is
still a problem.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.