bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

define search provider order of the first 4 positions

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: kar, Unassigned)

Tracking

24 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Currently, we seem to only be able to define positions 1 and 2 as the default order of search providers. We need to extend this to be able to define the default position of the first 4 providers in the list.
Margaret - Is the order of the list based on anything? Like the order in the list.xml file or maybe it's alphabetical?

(I mean for any provider that is not 1st or 2nd)
Flags: needinfo?(margaret.leibovic)
The code here makes it look like this: As long as we keep using prefs, we can set the order for any number of engines:
http://mxr.mozilla.org/mozilla-central/source/toolkit/components/search/nsSearchService.js#3167

In fact, I see "3" orders being used:
http://mxr.mozilla.org/mozilla-central/search?string=browser.search.order

This should just work.
We discovered that this already works fine
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Flags: needinfo?(margaret.leibovic)

Comment 5

5 years ago
I'd think that if 4 works, then by coincidence, and not by design. 1-3 should work, though.
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.