"allows pages to choose the fonts setting" is an hazardous option

RESOLVED DUPLICATE of bug 581647

Status

()

RESOLVED DUPLICATE of bug 581647
5 years ago
4 years ago

People

(Reporter: fabrice.salvaire, Unassigned)

Tracking

24 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130917102642

Steps to reproduce:

A long time ago I disabled "allows pages to choose the fonts setting" option naively. Unfortunately it took to me a long time to understand it was the reason with some glyphs on github was funny.  



Expected results:

Warn users they should not disable this option until they are really aware of the side effects.

Comment 1

5 years ago
Read "Checkboxes that kill your product" (http://limi.net/checkboxes-that-kill).

Mozilla can't educate each user.
Component: Untriaged → Preferences
(Reporter)

Comment 2

5 years ago
(In reply to Loic from comment #1)
> Read "Checkboxes that kill your product"
> (http://limi.net/checkboxes-that-kill).
> 
> Mozilla can't educate each user.

Interesting article. All these special settings should be only available within an expert mode. It is what I did for my own software.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 581647
You need to log in before you can comment on or make changes to this bug.