Force cache reload of a redirect from the address bar

UNCONFIRMED
Unassigned

Status

()

Firefox
Address Bar
--
enhancement
UNCONFIRMED
5 years ago
2 years ago

People

(Reporter: braiamp, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130911155223

Steps to reproduce:

1. Try to access a page directly without using the cache, or forcing the cache to refresh (i.e. clicking in a link, or typing a url in the address bar) for that specific instance.


Actual results:

Unless I disable the cache, Firefox will use the cache each time, and since the page could be redirected (i.e. using Moved Permanently or Moved Temporary) makes impossible to refresh the redirection until it expires. Or clearing the cache totally.


Expected results:

In Chrome I can press Ctrl + Enter and force the cache to be refreshed. Firefox lacks such functionality and users needs to disable the cache, go to the interesting url manually, activate the cache then press Ctrl + F5 to force the cache to refresh.
(Reporter)

Updated

5 years ago
Severity: normal → enhancement

Updated

5 years ago
Component: Untriaged → Networking
Product: Firefox → Core
ctrl-shift-f5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

5 years ago
@(In reply to Patrick McManus [:mcmanus] from comment #1)
> ctrl-shift-f5

That does nothing in any case. It doesn't have the desired behavior in Firefox 25. Please, confirm.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
its ctrl-shift-r .. sorry about that
(Reporter)

Comment 4

5 years ago
(In reply to Patrick McManus [:mcmanus] from comment #3)
> its ctrl-shift-r .. sorry about that

Still don't produce the desirable behavior, I want to before, I'm in the url, the cache to forget and get fresh from the server. Seems that I've not explained well. Here a test case:

1. Set up a web server and configure it to respond HTTP Moved Permanently -> mozilla.com. Use Firefox to access the page
2. Type the server address, Firefox will cache the answer and redirect you to mozilla.com
3. Remove the configuration from the server and add content.
4. Try to access with Firefox and you will be still taken to mozilla.com until you clear the cache or deactivate the cache completly.

Do the same with Chrome/ium and when you type the URL, instead of enter press Ctrl + Enter (for some reason, this has to be done twice), so the browser will not use the cache and fetch fresh content from the server.
ah - its the redirect that's of interest here.
Summary: Force cache reload from the address bar → Force cache reload of a redirect from the address bar
Component: Networking → Location Bar
Product: Core → Firefox
OS: Linux → All
Hardware: x86_64 → All
Whiteboard: [dupeme]
Version: 24 Branch → Trunk
The simplest solution here seems to be to be that when we reload (or shift-reload) a page, that we reload the URL that was originally loaded, rather than the one which is currently viewed.

I.e. the URL of the bookmarked that the user clicked, or the url that was typed into the URL bar. Not the URL that is currently in the URL bar. Most of the time those will be the same URL, but not if the original URL did a redirect.

To get to the URL that was originally loaded, we can either get it from the current document's nsIChannel (since http channels now remember their redirect chain). Or the Firefox front-end could simply remember it.
(Reporter)

Comment 7

2 years ago
There's a roundabout way, using the Dev tools and using the "Disable cache" option. Its effects are local (per tab) and only while the dev tools are open.
You need to log in before you can comment on or make changes to this bug.