CSS Background-size on body causes crash

RESOLVED DUPLICATE of bug 844819

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 844819
5 years ago
5 years ago

People

(Reporter: mcoates, Unassigned, NeedInfo)

Tracking

({regression})

26 Branch
All
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Created attachment 813975 [details]
test.html

The following style causes a crash in Aurora 26.0a2 and Nightly 27.01. This is not a problem in Release 24.

The problem is with including background-size.

<style>
    body
        {
          background-image:url('fox.jpg');
          background-color:#cccccc;
          background-size:100% 100%;
        }
</style>
Created attachment 813976 [details]
fox.jpg

image used for poc - shouldn't be related to the problem, but an image is needed for the crash to happen.
Created attachment 813977 [details]
HTML pointing to that image
Attachment #813975 - Attachment is obsolete: true
Hmm.  I don't see a crash here, on Mac.  In a debug build I do see:

WARNING: Surface size too large (exceeds CoreGraphics limit)!: file ../../../mozilla/gfx/thebes/gfxASurface.cpp, line 373

Michael, do you have a breakpad incident for the crash you see?
Flags: needinfo?(mcoates)
Keywords: regression
Here you go:
Nightly with fresh profile 
https://crash-stats.mozilla.com/report/index/852751ad-0299-452f-97ac-ee0552131006

mozalloc_abort(char const*) | Abort | NS_DebugBreak | gfxPlatform::GetSourceSurfaceForSurface(mozilla::gfx::DrawTarget*, gfxASurface*)
Flags: needinfo?(mcoates)
That sure looks like bug 844819, but that's reported on Windows.

I wonder whether we're managing to OOM in the graphics code somewhere here or something.
Component: DOM: CSS Object Model → Graphics
Flags: needinfo?(jmuizelaar)
bug 844819 includes mac crashes, too (bug 844819#c8 and duped bug 922806).
Group: core-security
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 844819
You need to log in before you can comment on or make changes to this bug.