dropdown sub menu on left hand side not folding itself when clicking outside

RESOLVED DUPLICATE of bug 926853

Status

developer.mozilla.org
Design
--
minor
RESOLVED DUPLICATE of bug 926853
5 years ago
5 years ago

People

(Reporter: Jean-Bernard Marcon, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
WHERE
example page https://developer.mozilla.org/en-US/docs/Tools
of the beta site
(looks like it is the same for all pages having the same kind of menu https://developer.mozilla.org/en-US/Apps?menu )

What happens
when clicking on one menu item in the left-hand site list, a submenu is dropped down, just fine. but if I click on any blank zone outside the menu the dropdown does *NOT* disappear. It disappears only if I click on another link.

What was expected
the submenu should fold itself as soon as clicking outside menu zone.
(Reporter)

Updated

5 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false

Comment 1

5 years ago
Collapsing when clicking anywhere outside seems like bad UX to me. The link collapses if you click it again, which is (for me, at least) expected behaviour.
Why would it close?  That doesn't make sense to me -- accordions don't close when outer-clicked.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

5 years ago
(In reply to David Walsh :davidwalsh from comment #2)
> Why would it close?  That doesn't make sense to me -- accordions don't close
> when outer-clicked.

ok guys this is a beautiful feature for you, this is a visual annoyance for me. By the way, did you notice that closing the menu when clicking outside is the normal behaviour of every item in menubar *in Firefox* for years? probably bad UX for you? File a bug just in case.

regards
-- Goofy
I'm going to reopen this and let me people chime in.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---

Comment 5

5 years ago
I believe this bug is a duplicate of another that asks to highlight where you are in the hierarchy on the left menu.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 926853
You need to log in before you can comment on or make changes to this bug.