The default bug view has changed. See this FAQ.

X-RAY Goggle tool should save automatically when idle.

RESOLVED WONTFIX

Status

Webmaker
X-Ray Goggles
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: adit bharadwaj, Assigned: pomax)

Tracking

Details

(Whiteboard: [icebox])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.69 Safari/537.36

Steps to reproduce:

i activated the x-ray goggles on the webpage.



Actual results:

the problem i faced is that tool got disappeared and den when i refreshed the page my whole edited webpage was gone my hard-work goes in vain. it also hangs the webpage when the tool gets disappear.


Expected results:

it should have some save-points in between saving all d editing i have been doing automatically so that even if something bad happen(internet problems,power ran out etc..)  we can go back to that save point and continue our work without any issue.

Comment 1

4 years ago
Makes sense as the current one X-Ray goggle faces several problems in during the editing. An autosave or click to save functionality, just as in thimble can be implemented. But for the big pages saving the whole page adds a more payload on the server, we can save the context of edits, it will work.


Cheers!
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

4 years ago
It also sounds like having a reload/leave confirmation would be valuable here, since the reason you'd want the autosave (be that localStorage or to the webmaker.org site) is because you otherwise lose data on an operation that takes you away from your current editing session. I have filed https://bugzilla.mozilla.org/show_bug.cgi?id=924533 for this feature, too.
I was going to file that too, but it looks like we already have it?  When I make a change and try to refresh the page, I get an onbeforeunload type handler asking if I'm sure I want to leave the page.
We're going to icebox this for now, and come back to it later.
Whiteboard: [icebox]
(Assignee)

Updated

2 years ago
Assignee: nobody → pomax
(Assignee)

Comment 5

2 years ago
Closing as part of maintenance. WONTFIX as "will not be tracked via Bugzilla", please use github.com/mozilla/goggles.webmaker.org instead
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.