Location bar, search box and Search button lack light background with dark background themes

RESOLVED WORKSFORME

Status

SeaMonkey
Themes
--
major
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: InvisibleSmiley, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 814044 [details]
regressed look

With dark background themes, the location bar, search bar and Search button now lack their light background. If browsing a secure site, the location bar shows a light yellow background, but otherwise it's transparent like the other two.

This is bad for UX since the missing background color leads to bad contrast, making text very hard to read.

Attached an image how it looks now on trunk.
(Reporter)

Comment 1

4 years ago
Also affected:
* MailNews Search Bar
* inactive tabs (browser, MailNews) show up black [maybe only with Aero or hw accel?]

The issue is not present on current Aurora (2.23a2) builds, only trunk (2.24a1).
(Reporter)

Comment 2

4 years ago
Created attachment 8340969 [details]
lwtheme regression evolution
(Reporter)

Comment 3

4 years ago
This first regressed between 2013-09-20 and 2013-09-21. Hence I guess it is fallout from bug 907926 (m-c cset e844f4ed3e1f). [Didn't bother to try and hunt down the second regression window.]

I can see (reproduce) the issue all the time in my Win7 x64 VM (running inside VMWare Workstation 9.0.1 with HW accel enabled) but not at home with native Win7 x64. With Firefox trunk nightlies however I cannot reproduce any similar issue on either machine.
Keywords: regressionwindow-wanted
(Reporter)

Comment 4

4 years ago
Meanwhile the problem has disappeared:

last broken: 2013-12-08 (2.25a1)
first good: 2013-12-11 (2.26a1)

Unfortunately there are no nightly builds available in between and I was unable to identify the bug/changeset that fixed the issue.

Current Aurora builds are OK as well. Once SM 2.24b1 becomes available I'll check again with that and if the issue is not present there either, I'll close this bug.
Flags: needinfo?(jh)
Whiteboard: verify WFM with SM 2.24b1
(Reporter)

Comment 5

4 years ago
Appears fixed with SM 2.24b1.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jh)
Resolution: --- → WORKSFORME
Whiteboard: verify WFM with SM 2.24b1
You need to log in before you can comment on or make changes to this bug.