Letters are rendered randomly bold in PDF

RESOLVED DUPLICATE of bug 921465

Status

()

RESOLVED DUPLICATE of bug 921465
5 years ago
5 years ago

People

(Reporter: david.balazic, Unassigned)

Tracking

24 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 814097 [details]
examplePDF.png

Opening the URL in Firefox 24 shows the document with bad text rendering.
See screenshot.
(Reporter)

Comment 1

5 years ago
Created attachment 814098 [details]
The problematic PDF

I attach the PDF for the case it is not available any more on the original location.
I couldn't reproduce the issue using latest Aurora and Fx 24 en-US build. 
Are you using a locale Firefox version?

Can you reproduce this issue in safe mode? How about on a clean profile?
http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Thanks
(Reporter)

Comment 3

5 years ago
What do you mean by "locale Firefox version"?
It is the US_EN version.

I tried a different profile and there it works OK.
I also tried FF on another PC (running WinXP) and there the same problem happens.

I'll attach a list of addons in the problem profile.
(Reporter)

Comment 4

5 years ago
Created attachment 814111 [details]
addons.png

List of addons in the profile where the problem happens.

Note: the Trouble free profile has these two add-ons (the plugins are same as they are per PC, not per user profile):
 - Dictionary for the Slovene language 0.1.1.1
 - Lazarus: Form Recovery 2.3
(Reporter)

Comment 5

5 years ago
The problem persists even after disabling all add-ons (and restarting FF).
I did that on the WinXP machine (that I access over Remote Desktop).
On this machine in the 100% zoom level (smaller zooms do not exibit the problem), only the letters l and i are rendered bolder that the rest. Increasing the zoom level (enlarging the image) makes more and more letters bolder than the rest.

Comment 6

5 years ago
I think it's related to HWA. With HWA disabled, I'm able to reproduce it.
And I guess on your Win XP machine, there is no HWA enabled by default, so the issue is visible.
(Reporter)

Comment 7

5 years ago
On my Windows 8 system the problem does not happen, with HWA on or off.
Confirmed on WinXP SP3 with HWA enabled, Japanese Windows
I guess this is a fallout from <https://github.com/mozilla/pdf.js/pull/3209>.
Status: UNCONFIRMED → NEW
Ever confirmed: true
https://github.com/mozilla/pdf.js/issues/3563 ?
This is especially severe on Japanese Windows because its default serif font (MS Mincho) is rendered without ClearType. There is no way to enable ClearType for East-Asian fonts if the font contains embedded bitmap.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 921465
You need to log in before you can comment on or make changes to this bug.