EML files in attachments can't be opened ("Empty attachments" by open, "Save As" does do nothing

UNCONFIRMED
Unassigned

Status

Thunderbird
Message Reader UI
UNCONFIRMED
4 years ago
3 years ago

People

(Reporter: Chris2mop, Unassigned)

Tracking

24 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 814129 [details]
FW_ tr_ L'école .!.eml

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

This is the follow up of arkaine55 append to bug 580017
This bug is still NOT resolved in Thunderbird 17.0.8 (win 7 sp1, all patches applied)

I tryed to open an attached .eml file


Actual results:

thunderbird says: Empty attachments
Save or detach do nothing althougt the saving procedd is OK (asking where to save it)-> the file is never saved/detached
I tryed to rename the eml file to txt file before saving, but nothing happened


Expected results:

first, Opening the file
next, saving it

Cannot attach an .eml file (see above) but i can mail one if required (geme a mail address)

Last minute:
i have sent my eml file to my UBUNTU machine and it WORKS (i can open , view and save the file). thunderbird is version: 24.0 
According to this result i upgraded my windows thunderbird 17.0.8 to 24.0 but
It still FAILS in windows (same eml file on BOTH machines)
I attach the file "FW_ tr_ L'école .!.eml" for investigation (dont worry, this file contains a joke, but it is virus proof (tested with avira)) 
At the end, before submitting the bug,  i tryed to open the eml file from the directory where i have saved it .... dble clicking on it and TB opened it....
But it STILL fail in TB environment ????????
(Reporter)

Updated

4 years ago
Severity: normal → critical
Version: 17 → 24
(Reporter)

Comment 1

4 years ago
Additional info:
Sent this mail to my WIN8 Laptop  with TB 17.0.7
TB CAN OPEN and show this eml...
Seems the problem related to WIN7/TB user interface ???
(Reporter)

Comment 2

4 years ago
More info:
To confirm a win7 problem: 
In VirtualBox server (my win 7pro machine)i have installed the same win 7 pro system as guest. Then i resent the "famous" .eml file to my mailbox and i opened it with TB 24.0 (in virtual guest) ..... TB could open it successfully ???
Looking at the original .eml attachment , i saw a size of 35.6 Ko. The resent attached file is only
26.0 Ko. I think the problem is in the file content ???, but i cant either detach or save it due to the bug... 
Note: All .eml received on my win7 pro basic machine are unreadeable not only this sample
(Reporter)

Comment 3

4 years ago
All previous tests i did were unaccurate because there were based on the fact that the  resent .eml mail
was the same as the original one. It's wrong...TB modifies it, and the result is that it becomes readable...
So from that, i see a temporary circumvention: RESENT Back the received unreadable .eml to the same email address and that's it. Now it comes readable................
To go further, the unreadable .eml must be analysed, but i have no mean to get it...
Severity: critical → normal

Comment 4

3 years ago
I have this problem too, but in Seamonkey (2.23 and .2.26) and can confirm: from the mail component, double-clicking .eml attachments causes the "What should Seamonkey do with this file?" dialog to open (defaulting to "Seamonkey Composer" as helper application which causes an endless loop - because Composer then asks the very same question). 
Saving the .eml attachment to a file and chosing "File - Open" causes the .eml file be display properly in a separate message window.

I cannot define "/usr/bin/seamonkey -mail" as helper application for .eml files.

Can a moderator please assign this bug to Seamonkey as well? Thanks.
You need to log in before you can comment on or make changes to this bug.