[B2G][Browser]Web surfing behavior demonstrates intermittent browser tab crashes and link non-responsiveness on some sites

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Montoya Clemmons (MClemmons), Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: burirun2, [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 814152 [details]
LogcatBrowserTabCrash10072013 for mlb.com

Description: While surfing on certain heavy content websites such as mlb.com and usatoday.com, selection of links are sometimes not responsive and the browser tab crashes while navigating a page or stationary on that page.

Steps to Reproduce:
1. Tap Browser App
2. Type mlb.com in URL field


Actual:
Page loads but sometimes links don't react to user selection.
When links do react to user selection, sometimes, browser tab crashes

Expected:
Page loads and links react to user selection
When links react to user selection, browser displays content and not crash

Environmental Variables
Gaia   85c4af3f48a91878d565f518ba0eed68f0628e21
Gecko f067799dff06
BuildID 20131007004003
Version 26.0a2

Notes:
Repro frequency: (10/20 - 50 percent)
See attached: logcat for experience with mlb.com
Other notes: reproducible behavior on usatoday.com
There's an intermix of two styles of errors being seen here.

10-07 12:02:58.370: I/Gecko(5784): No permission to use the keyboard API for http://mlb.mlb.com

10-07 12:03:13.830: E/msm7627a.gralloc(138): gralloc failed err=Out of memory
10-07 12:03:13.830: W/GraphicBufferAllocator(138): alloc(480, 1985, 1, 00000133, ...) failed -12 (Out of memory)

No keyboard permission would definitely cause the tab to be killed. That's my guess at the problem here. The other error seems less probable for causing the tab to be killed, but it could be a different issue potentially.

Let's focus on the permissions issue here. A regression range will help figure this out.
blocking-b2g: --- → koi?
Component: Gaia::Browser → General
Gregor,

Please comment if this is a Systems FE issue.
Flags: needinfo?(anygregor)
(Reporter)

Updated

4 years ago
Whiteboard: burirun2
QA Contact: ktucker
Tim,

Please review this bug from keyboard perspective: 10-07 12:02:58.370: I/Gecko(5784): No permission to use the keyboard API for http://mlb.mlb.com
Flags: needinfo?(timdream)
I don't think keyboard is related to this bug in any way.

The output came from here.
http://dxr.mozilla.org/mozilla-central/source/dom/inputmethod/MozKeyboard.js#l48
Flags: needinfo?(timdream)
It is difficult to find the regression window on this issue because it is very intermittent. Also, both the USA Today and MLB websites are loaded as a desktop website on Buri v 1.2.0 Mozilla RIL instead of the mobile version which is causing the pages to load very slowly. The pages are very unresponsive until the page completely loads. Sometimes only half the page is loaded on the MLB website. The browser is not crashing but at times the user will get the "Well, this is embarrassing. We tried to display this Web page, but it's not responding." error message when tapping on links on the pages. 

On Leo v 1.1.0 COM RIL, USA Today is loaded as a mobile website. www.mlb.com is always loaded as a desktop website on both v 1.1.0 and v 1.2.0. On Android, the mobile website is loaded for both www.mlb.com and www.usatoday.com.
(In reply to ktucker from comment #5)
> It is difficult to find the regression window on this issue because it is
> very intermittent. Also, both the USA Today and MLB websites are loaded as a
> desktop website on Buri v 1.2.0 Mozilla RIL instead of the mobile version
> which is causing the pages to load very slowly. The pages are very
> unresponsive until the page completely loads. Sometimes only half the page
> is loaded on the MLB website. The browser is not crashing but at times the
> user will get the "Well, this is embarrassing. We tried to display this Web
> page, but it's not responding." error message when tapping on links on the
> pages. 
> 
> On Leo v 1.1.0 COM RIL, USA Today is loaded as a mobile website. www.mlb.com
> is always loaded as a desktop website on both v 1.1.0 and v 1.2.0. On
> Android, the mobile website is loaded for both www.mlb.com and
> www.usatoday.com.

How intermittent is the issue on the latest build available (i.e. reproduction rate)?
I was able to reproduce the issue after 15 attempts on the latest Buri v 1.2.0 Mozilla RIL

Environmental Variables
Device: Buri v 1.2.0 Mozilla RIL
Build ID: 20131017004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/7ca5d1e81d37
Gaia: dbcc171eae6b4d9d168a48291d5ea54c7580561a
Platform Version: 26.0a2

The error message "Well, this is embarrassing. We tried to display this Web page, but it's not responding." was encountered when tapping on links on the MLB page.


Regression Window:

The issue reproduces on the 10/06 Buri v 1.2.0 Mozilla RIL

Environmental Variables
Device: Buri v 1.2.0 Mozilla RIL
Build ID: 20131006004004
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/8b4152d366c3
Gaia: 4e0125e47bb109cc7e7a91559d120b78bf65ace1
Platform Version: 26.0a2

The error message "Well, this is embarrassing. We tried to display this Web page, but it's not responding." was encountered when tapping on links on the MLB page. 


The issue did not reproduce on the 10/04 Buri v 1.2.0 Mozilla RIL after 50 attempts.

Environmental Variables
Device: (example:Leo v 1.1.0 Mozilla/ COM RIL)
Build ID: 20131004004003
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/a4b7282df517
Gaia: 9e21b6bea92fdafcb6787120a8cde0eb25a50495
Platform Version: 26.0a2

No error message was encountered when tapping on links on the MLB page.
Keywords: regressionwindow-wanted
The error in question firing is a permissions issue that looks like was implemented by fabrice. He might have input on what's failing here.
QA Wanted - this should be fixed now. Can someone confirm?
Keywords: qawanted
I can't reproduce. Please reopen if it is still reproducible.
Status: NEW → RESOLVED
blocking-b2g: koi? → ---
Last Resolved: 4 years ago
Flags: needinfo?(anygregor)
Resolution: --- → WORKSFORME
Whiteboard: burirun2 → burirun2, [systemsfe]

Updated

4 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.