If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][SMS] A MMS that has not been downloaded yet will have an infinite spinner when trying to download it after changing the SIM

RESOLVED DUPLICATE of bug 981077

Status

Firefox OS
RIL
RESOLVED DUPLICATE of bug 981077
4 years ago
4 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 affected, b2g-v1.2 affected)

Details

(Whiteboard: burirun2, burirun3)

Attachments

(1 attachment)

Created attachment 814180 [details]
MMSdownloadlog.txt

Description:
A MMS that has not been downloaded yet will have an infinite spinner when trying to download it after changing the SIM.

Repro Steps:
1)  Updated Buri to Build ID: 20131007004003
2)  Open Settings and tap on "Cellular and Data".
3)  Tap on "Message Settings".
4)  Tap on the box below "Auto retrieve" and set it to "OFF".
5)  Tap on "Ok" in the top right corner of the screen to save the setting.
6)  Send a MMS from another phone to the test device.(Do not download the MMS yet)
7)  Power down the test phone and insert a new SIM.
8)  Power the phone back on and top on the "Messaging" icon.
9)  Open the previously received MMS thread.
10) Tap on "Download" to download the MMS.

Actual:
The MMS will not download. The user will see an infinite spinner.

Expected:
The MMS should not show the option to "Download" after changing the SIM.

Environmental Variables
Device: Buri v 1.2.0 Mozilla RIL
Build ID: 20131007004003
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/f067799dff06
Gaia: 85c4af3f48a91878d565f518ba0eed68f0628e21
Platform Version: 26.0a2
RIL Version: 01.02.00.019.056 

Notes:
Repro frequency: 100%
Test Suite Name: Messages-041
UCID: MMS
Link to failed test case: https://moztrap.mozilla.org/manage/case/8275/
See attached: logcat
This issue also occurs on Leo v 1.1.1.0

Environmental Variables
Device: Leo v 1.1.1.0 COM RIL
Build ID: 20131001041206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c630289d6388
Gaia: 02b975e6ce12922928c74276ac7d19432a03f126
Platform Version: 18.1
RIL Version: 01.01.00.019.240 

The MMS download option appears on a MMS received by a different sim on the message thread. The user will see an infinite spinner when trying to download the MMS.
Component: Gaia::SMS → RIL
Flags: needinfo?(vyang)
Whiteboard: burirun2 → burirun2, burirun3
Hey Bevis, I think we have another bug for this issue and that it's now fixed on master. Can you help me finding the correct bug?
Flags: needinfo?(vyang) → needinfo?(btseng)
(In reply to Julien Wajsberg [:julienw] from comment #2)
> Hey Bevis, I think we have another bug for this issue and that it's now
> fixed on master. Can you help me finding the correct bug?

Yes, we have formal solution in master.
This is a duplicated bug of bug 981077, and will have a proper message provided in bug 990020.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(btseng)
Resolution: --- → DUPLICATE
Duplicate of bug: 981077
You need to log in before you can comment on or make changes to this bug.