Closed Bug 924314 Opened 6 years ago Closed 6 years ago

missing animation in menu panel after right click

Categories

(Firefox :: Toolbars and Customization, defect)

27 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29

People

(Reporter: fx4waldi, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Keywords: polish, Whiteboard: [Australis:P-])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20131007040202

Steps to reproduce:

1. Open menu panel
2. Right click on menu panel
3. Click on History, Developer etc.


Actual results:

Subview isn't animated


Expected results:

Subview should be animated
Component: Untriaged → Toolbars and Customization
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Australis:M?][Australis:P5]
Keywords: polish
Whiteboard: [Australis:M?][Australis:P5] → [Australis:M?][Australis:P-]
Iam interested to work on this bug. I need some more information. 
Thanks in advance. :)
(In reply to cptanu from comment #1)
> Iam interested to work on this bug. I need some more information. 
> Thanks in advance. :)

The cause of this issue hasn't been determined yet. It is not a good bug to work on if this is your first bug you are fixing within Firefox. You may still investigate the cause of this and try to put together a fix but I would recommend finding a bug from http://www.joshmatthews.net/bugsahoy/?ff=1 instead.
I looked closer this bug and it turned out that the animation disappears because the panel does not have the attribute "panelopen".

handleEvent in PanelUI.xml:
popupshowing   (Opening the panel menu - panelopen=true)
overflow       (Opening the subview  - panelopen==true - animation is done)

popupshowing   (Opening the panel menu - panelopen=true)
popupshowing   (Opening the context menu - panelopen=true)
popuphidden    (Closing the context menu - panelopen is removed)
overflow       (Opening the subview  - panelopen==null - animation is not done)

The easiest way is a slight change in the css. This is not fix the problem, but only the workaround. I do not know if it causes any other bugs
panelUI.css

 .panel-subviews {
   -moz-stack-sizing: ignore;
   transform: translateX(0);
   overflow-y: auto;
+  transition: transform 150ms;
 }
 
- .panel-subviews[panelopen] {
-   transition: transform 150ms;
- }
(In reply to fx4waldi from comment #3)
> popuphidden    (Closing the context menu - panelopen is removed)

That shouldn't remove the attribute. That's probably not hard to fix. I'll try to sort this out later today or this week.
That wasn't too hard. I expect this might also fix bug 961535.
Attachment #8364982 - Flags: review?(mdeboer)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8364982 [details] [diff] [review]
Australis panel binding shouldn't care about popup events from other things,

Review of attachment 8364982 [details] [diff] [review]:
-----------------------------------------------------------------

Nice! Ship it!
Attachment #8364982 - Flags: review?(mdeboer) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/5e26632e3eb7
Whiteboard: [Australis:M?][Australis:P-] → [Australis:P-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/5e26632e3eb7
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P-][fixed-in-fx-team] → [Australis:P-]
Target Milestone: --- → Firefox 29
You need to log in before you can comment on or make changes to this bug.