Closed Bug 924324 Opened 8 years ago Closed 8 years ago

Intermittent PROCESS-CRASH | /tests/dom/imptests/editing/selecttest/test_collapse.html | Assertion failure: !cx->isExceptionPending(), at js/src/jit/IonBuilder.cpp:3766 | application crashed [@ js::jit::IonBuilder::inlineScriptedCall(js::jit::CallInfo &,J

Categories

(Core :: JavaScript Engine: JIT, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 923614

People

(Reporter: cbook, Unassigned)

References

()

Details

(Keywords: assertion)

Crash Data

Windows XP 32-bit mozilla-inbound debug test mochitest-2 on 2013-10-08 00:59:52 PDT for push 5c23662223d6

slave: t-xp32-ix-092

https://tbpl.mozilla.org/php/getParsedLog.php?id=28817925&tree=Mozilla-Inbound

Assertion failure: !cx->isExceptionPending(), at e:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/js/src/jit/IonBuilder.cpp:3766
PROCESS-CRASH | /tests/dom/imptests/editing/selecttest/test_collapse.html | application crashed [@ js::jit::IonBuilder::inlineScriptedCall(js::jit::CallInfo &,JSFunction *)]
Return code: 1

01:15:05  WARNING -  PROCESS-CRASH | /tests/dom/imptests/editing/selecttest/test_collapse.html | application crashed [@ js::jit::IonBuilder::inlineScriptedCall(js::jit::CallInfo &,JSFunction *)]
01:15:05     INFO -  Crash dump filename: c:\docume~1\cltbld~1.t-x\locals~1\temp\tmpyv4qax\minidumps\f8654f27-9665-4578-ab1e-f2c5f90c8892.dmp
01:15:05     INFO -  Operating system: Windows NT
01:15:05     INFO -                    5.1.2600 Service Pack 3
01:15:05     INFO -  CPU: x86
01:15:05     INFO -       GenuineIntel family 6 model 30 stepping 5
01:15:05     INFO -       8 CPUs
01:15:05     INFO -  Crash reason:  EXCEPTION_BREAKPOINT
01:15:05     INFO -  Crash address: 0xfd0cc4
01:15:05     INFO -  Thread 0 (crashed)
01:15:05     INFO -   0  mozjs.dll!js::jit::IonBuilder::inlineScriptedCall(js::jit::CallInfo &,JSFunction *) [IonBuilder.cpp:5c23662223d6 : 3704 + 0x35]
01:15:05     INFO -      eip = 0x00fd0cc4   esp = 0x0012c38c   ebp = 0x0012c848   ebx = 0x2600a080
01:15:05     INFO -      esi = 0x0012cbe4   edi = 0x0012c900   eax = 0x00000000   ecx = 0xbc9e993e
01:15:05     INFO -      edx = 0x10361f48   efl = 0x00200216
01:15:05     INFO -      Found by: given as instruction pointer in context
01:15:05     INFO -   1  mozjs.dll!js::jit::IonBuilder::inlineSingleCall(js::jit::CallInfo &,JSFunction *) [IonBuilder.cpp:5c23662223d6 : 4069 + 0xb]
01:15:05     INFO -      eip = 0x00fa8fa6   esp = 0x0012c850   ebp = 0x0012c85c
01:15:05     INFO -      Found by: call frame info
01:15:05     INFO -   2  mozjs.dll!js::jit::IonBuilder::inlineCallsite(js::Vector<JSObject *,4,js::jit::IonAllocPolicy> &,js::Vector<JSObject *,4,js::jit::IonAllocPolicy> &,bool,js::jit::CallInfo &) [IonBuilder.cpp:5c23662223d6 : 4111 + 0x8]
01:15:05     INFO -      eip = 0x00fcd215   esp = 0x0012c864   ebp = 0x0012c8a8
01:15:05     INFO -      Found by: call frame info
01:15:05     INFO -   3  mozjs.dll!js::jit::IonBuilder::jsop_call(unsigned int,bool) [IonBuilder.cpp:5c23662223d6 : 4944 + 0x1c]
01:15:05     INFO -      eip = 0x00fcd7eb   esp = 0x0012c8b0   ebp = 0x0012c99c
01:15:05     INFO -      Found by: call frame info
01:15:05     INFO -   4  mozjs.dll!js::jit::IonBuilder::inspectOpcode(JSOp) [IonBuilder.cpp:5c23662223d6 : 1471 + 0x26]
01:15:05     INFO -      eip = 0x00fce89e   esp = 0x0012c9a4   ebp = 0x0012ca2c
01:15:05     INFO -      Found by: call frame info
01:15:05     INFO -   5  mozjs.dll!js::jit::IonBuilder::traverseBytecode() [IonBuilder.cpp:5c23662223d6 : 1165 + 0xa]
01:15:05     INFO -      eip = 0x00fd008d   esp = 0x0012ca34   ebp = 0x0012caa8
01:15:05     INFO -      Found by: call frame info
01:15:05     INFO -   6  mozjs.dll!js::jit::IonBuilder::build() [IonBuilder.cpp:5c23662223d6 : 605 + 0x6]
01:15:05     INFO -      eip = 0x00fd071f   esp = 0x0012cab0   ebp = 0x0012cadc
01:15:05     INFO -      Found by: call frame info
01:15:05     INFO -   7  mozjs.dll!js::jit::AnalyzeNewScriptProperties(JSContext *,JSFunction *,js::types::TypeObject *,JS::Handle<JSObject *>,js::Vector<js::types::TypeNewScript::Initializer,0,js::TempAllocPolicy> *) [IonAnalysis.cpp:5c23662223d6 : 2090 + 0xa]
01:15:05     INFO -      eip = 0x00fa67f8   esp = 0x0012cae4   ebp = 0x0012d110
01:15:05     INFO -      Found by: call frame info
01:15:05     INFO -   8  mozjs.dll!CheckNewScriptProperties [jsinfer.cpp:5c23662223d6 : 2928 + 0x2e]
01:15:05     INFO -      eip = 0x00e0ab8c   esp = 0x0012d118   ebp = 0x0012d1b8
01:15:05     INFO -      Found by: call frame info
01:15:05     INFO -   9  mozjs.dll!`anonymous namespace'::ConstraintDataFreezeConfiguredProperty::constraintHolds(JSContext *,js::types::HeapTypeSetKey const &,js::types::TemporaryTypeSet *) [jsinfer.cpp:5c23662223d6 : 1066 + 0x12]
Depends on: 939369
This is probably fixed by the patch that just landed in bug 923614.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 923614
You need to log in before you can comment on or make changes to this bug.