bn-IN homepage has Firefox 3.6 download

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: pascalc, Assigned: pmac)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1175027] , URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
See:
https://www-dev.allizom.org/bn-IN/

The logic for download boxes on bedrock does not check if the localized build is still a supported one which means we can't push the home page for Bengali as we currently don't ship it on the release channel.

We need to find a way to be able to push a localized mozilla.org website in Bengali even though we don't have Firefox yet in Bengali .

Not showing the download box on the homepage would be fine for me until we either fix the download box logic to show something more current (an Aurora download box for example) or we ship Bengali on the release channel.

Thanks
Can we show a download button to download Fx desktop in English?  That would be my preference.
(Reporter)

Comment 2

5 years ago
that would be fine and that would be the behaviour we had on the php site too (no supported localized build, show en-US)
Cmore- Is this a mozilla.org issue or a Rel Eng issue?  Thx.

Comment 4

5 years ago
My preference options:

1) show english for non-supported locales on release

2) don't show the download button in generic areas of the website. 

I would prefer option 1 and this should not Rel Eng and we would need the download buttons to present en-US if it is a non-supported language. My question is if this data is in bedrock to be able to do a condition statement on it?
(Reporter)

Comment 5

5 years ago
(In reply to Chris More [:cmore] from comment #4)
> I would prefer option 1 and this should not Rel Eng and we would need the
> download buttons to present en-US if it is a non-supported language. My
> question is if this data is in bedrock to be able to do a condition
> statement on it?

This data is in bedrock since it imports the json data of builds from product-details, but the code we have that generate these buttons does not use it. The code on the php side which uses the same data does so it should not be a problem to add that to python.
Pascal - What is the timeline for localizing the homepage into Bengali?  Thx.
(Reporter)

Comment 7

5 years ago
the homepage is already translated but not pushed to prod because of the download box issue
Pmac - could you please review this bug?  We need to provide an English download button on a Bengali-localized mozilla.org homepage.  According to Pascal:
:This data is in bedrock since it imports the json data of builds from product-details, but the code we have that generate these buttons does not use it. The code on the php side which uses the same data does so it should not be a problem to add that to python." 

Could you please comment on level of effort and who could do this work?

Thx,
Jen
Flags: needinfo?(pmac)
I can do it. I think the level of effort will not be too high because pascalc is right about the product-details data. I'm looking into the details and code now and will provide a better estimate shortly.
Assignee: nobody → pmac
Status: NEW → ASSIGNED
Flags: needinfo?(pmac)
Does the new Hindi download page make this one a close/won't fix?

https://www.mozilla.org/hi-IN/firefox/new/
Flags: needinfo?(pascalc)
(In reply to Jennifer Bertsch [:jbertsch] from comment #10)
> Does the new Hindi download page make this one a close/won't fix?
> https://www.mozilla.org/hi-IN/firefox/new/

Nope, those are two different locales (Bengali->bn-IN, Hindi->hi-IN).

The Bengali home page still lets you download Fx 3.6.28
https://www-dev.allizom.org/bn-IN/
Flags: needinfo?(pascalc)

Updated

5 years ago
Blocks: 813052
Whiteboard: [kb=1175027]

Updated

5 years ago
Duplicate of this bug: 922180

Comment 13

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/067f64cfe13082f49a7d6cd69da344d07ca61477
Fix bug 924347: Fx download button default to en-US.

Previously for release Fx it would search for the build
in the locale that had the largest version number that
wasn't a pre-release or ESR. For some locales this was
returning a very old release. This alters this to only
return the latest release, and thus causes the button
to always give the latest release by defaulting to en-US
if no localized build is available.

https://github.com/mozilla/bedrock/commit/faf74c547075d001e0dd73dcfb7a070ed17b41f1
Merge pull request #1384 from pmclanahan/fix-download-button-version-checking-924347

Fix bug 924347: Fx download button default to en-US.

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Verified FIXED on staging; https://www.allizom.org/bn-IN/firefox/new/ gives me https://download.mozilla.org/?product=firefox-stub&os=win&lang=en-US, which is the latest US-English build.
Also verified on prod, now that we've pushed: https://www.mozilla.org/bn-IN/firefox/new/ give me the US build of latest Firefox: https://download.mozilla.org/?product=firefox-stub&os=win&lang=en-US

Verified FIXED.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 16

5 years ago
Reopening, AFAIK this is not working, we haven't activated bn-IN on stage on prod therefore the testing was done on the older (orange) PHP version of this page which doesn't  have this bug.

If I look at Bedrock on master it's still proposing the bn-IN build but links to 25.0:
https://www-dev.allizom.org/b/bn-IN/firefox/new/
-> https://download.mozilla.org/?product=firefox-25.0&os=linux&lang=bn-IN

(Note that bn-IN is still automatically built and available on the ftp, but we don't want to propose it for download yet for quality reasons)
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(In reply to Pascal Chevrel:pascalc from comment #16)
> If I look at Bedrock on master it's still proposing the bn-IN build but
> links to 25.0:
> https://www-dev.allizom.org/b/bn-IN/firefox/new/
> -> https://download.mozilla.org/?product=firefox-25.0&os=linux&lang=bn-IN

We have enabled the home page though, and there's a download button also on the plugincheck page (visible if your user agent is not Firefox).

Affected locales: bn-IN, ku, oc, my. First two let you download the localized build, last two give you a 404 page.

It's not pretty but to avoid showing people 404 pages or download obsolete builds I temporarily deactivated those pages (not all were active or included in rewrite rules): reference r122493 and r122494.
DOH! Yup. It now falls back to the en-US builds, but fails to update the locale on the URL :( I'll have a PR soon.
Created attachment 8333915 [details] [review]
pull request

This should actually fix it. Better test for this in the future as well.

Comment 20

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/cfa0f8ba92adb89c8d394887656bb44f4893b61c
Fix bug 924347: Fall back to en-US download locale.

If no localized Fx build exists for the latest version
fall back to an en-US download link.

https://github.com/mozilla/bedrock/commit/d45a59e42a447a130235a051001e3db7c3563c37
Merge pull request #1410 from pmclanahan/fx-download-broken-link-no-build-924347

Fix bug 924347: Fall back to en-US download locale.

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Confirmed on all four locales (bn-IN, ku, oc, my) on home on www-dev: button gives you the English download.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
fixed on dev https://www-dev.allizom.org/bn-IN/
https://www-dev.allizom.org/ku/
https://www-dev.allizom.org/my/
https://www-dev.allizom.org/oc/
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
fixed on prod
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.