fix various integer comparison warnings in QuartzSupport.mm

RESOLVED FIXED in mozilla27

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jaas, Assigned: jaas)

Tracking

(Blocks 1 bug)

Trunk
mozilla27
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Posted patch Fix v1.0Splinter Review
0:00.82 QuartzSupport.o
 0:01.43 Warning: -Wsign-compare in /Users/josh/src/mozilla/ff_trunk_debug/gfx/2d/QuartzSupport.mm: comparison of integers of different signs: 'int' and 'uint32_t' (aka 'unsigned int')
 0:01.43 /Users/josh/src/mozilla/ff_trunk_debug/gfx/2d/QuartzSupport.mm:546:14: warning: comparison of integers of different signs: 'int' and 'uint32_t' (aka 'unsigned int') [-Wsign-compare]
 0:01.44   if (aWidth == mUnsupportedWidth &&
 0:01.44       ~~~~~~ ^  ~~~~~~~~~~~~~~~~~
 0:01.44 Warning: -Wsign-compare in /Users/josh/src/mozilla/ff_trunk_debug/gfx/2d/QuartzSupport.mm: comparison of integers of different signs: 'int' and 'uint32_t' (aka 'unsigned int')
 0:01.44 /Users/josh/src/mozilla/ff_trunk_debug/gfx/2d/QuartzSupport.mm:547:15: warning: comparison of integers of different signs: 'int' and 'uint32_t' (aka 'unsigned int') [-Wsign-compare]
 0:01.44       aHeight == mUnsupportedHeight) {
 0:01.44       ~~~~~~~ ^  ~~~~~~~~~~~~~~~~~~
 0:01.44 Warning: -Wsign-compare in /Users/josh/src/mozilla/ff_trunk_debug/gfx/2d/QuartzSupport.mm: comparison of integers of different signs: 'size_t' (aka 'unsigned long') and 'int'
 0:01.44 /Users/josh/src/mozilla/ff_trunk_debug/gfx/2d/QuartzSupport.mm:810:32: warning: comparison of integers of different signs: 'size_t' (aka 'unsigned long') and 'int' [-Wsign-compare]
 0:01.44     if (mIOSurface->GetWidth() != width || mIOSurface->GetHeight() != height) {
 0:01.44         ~~~~~~~~~~~~~~~~~~~~~~ ^  ~~~~~
 0:01.44 Warning: -Wsign-compare in /Users/josh/src/mozilla/ff_trunk_debug/gfx/2d/QuartzSupport.mm: comparison of integers of different signs: 'size_t' (aka 'unsigned long') and 'int'
 0:01.44 /Users/josh/src/mozilla/ff_trunk_debug/gfx/2d/QuartzSupport.mm:810:68: warning: comparison of integers of different signs: 'size_t' (aka 'unsigned long') and 'int' [-Wsign-compare]
 0:01.44     if (mIOSurface->GetWidth() != width || mIOSurface->GetHeight() != height) {
 0:01.44                                            ~~~~~~~~~~~~~~~~~~~~~~~ ^  ~~~~~~
 0:01.50 4 warnings generated.
Attachment #814427 - Flags: review?(mstange)
Attachment #814427 - Flags: review?(mstange) → review+
Duplicate of this bug: 858274
https://hg.mozilla.org/mozilla-central/rev/a78b66ab1e0a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.