CreateOffer doesn't call onError callback when limit is reached

RESOLVED FIXED

Status

()

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Makkes, Assigned: abr)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 814481 [details]
webrtc-limit.html

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130911164256

Steps to reproduce:

There's a limit of 50 PCs hard-coded in phone_platform_constants.h (MAX_CALLS). Creating 51 PCs and then calling createOffer on the last one doesn't succeed. That would be ok if the error callback would be called with a meaningful message but it is actually never called. See the attached code for reproduction.
(Assignee)

Updated

5 years ago
Component: WebRTC → WebRTC: Signaling
(Assignee)

Updated

5 years ago
Assignee: nobody → adam
This no longer applies since sdparta.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.