Does Firefox for Windows support "video/quicktime" in addition to "video/mp4"?

RESOLVED WONTFIX

Status

()

Core
Audio/Video
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: Šime Vidas, Unassigned)

Tracking

24 Branch
x86_64
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

Now that Firefox for Windows supports "video/mp4" files in <video> elements, does this also include "video/quicktime" files? 

1. Page with "video/mp4" file in <video>: http://www.webpayload.com/video-episodes/speed-part-1
2. Page with "video/quicktime" file in <video>: http://www.webpayload.com/video-episodes/forms-part-2-increasing-conversions-with-good-use-of-forms


Actual results:

Firefox is able to play the video on the 1. page, but not the video on the 2. page.


Expected results:

Firefox should be able to play both variants of MP4 files, "video/mp4" and "video/quicktime".

Or?
(Reporter)

Comment 1

5 years ago
Created attachment 814491 [details]
Screenshot that shows that Firefox isn't able to play "video/quicktime"

Comment 2

5 years ago
Both these videos are H.264 videos, so as far as I understand, both should be supported in systems that have these codecs built-in.
(Reporter)

Comment 3

5 years ago
The second URL I posted above now contains a "video/mp4". (That website, Web Payload, converted their videos to "video/mp4", after my report.)

Here is an alternative URL that contains a "video/quicktime": http://freecourses.tutsplus.com/30-days-to-learn-html-and-css/images.html
Reproduced on latest Aurora (20131014004003): "Error loading media: File could not be played" is displayed on the video.

Browser's console:
HTTP "Content-Type" of "video/quicktime" is not supported. Load of media resource http://d2qpdl5ntmaj0h.cloudfront.net/tutspremium/courses_$folder$/30DaysHTMLCSS/nostring/Day-10-Images.mov failed. images.html
"Error playing media: " [object MediaError]
Component: Untriaged → Plug-ins
Product: Firefox → Core

Comment 5

5 years ago
No, we do not and AFAIK will not support video/quicktime in the HTML <video> element.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Updated

5 years ago
Component: Plug-ins → Video/Audio

Comment 6

5 years ago
Would you care to elaborate why? The codec is (AFAICT) the same as the supported "video/mp4".
Why should the MIME type difference matter?

Comment 7

5 years ago
(In reply to Yoav Weiss from comment #6)
> Would you care to elaborate why? The codec is (AFAICT) the same as the
> supported "video/mp4".
> Why should the MIME type difference matter?

video/mp4 and video/quicktime are different container formats. Although they can have streams inside them encoded using the same codecs, the container itself is a different format. I'm not familiar with how compatible they are (as MP4 was based on MOV at some point IIRC) but that's the reason why the difference matters. We don't use a MOV container parser.
You need to log in before you can comment on or make changes to this bug.