[B2G][Email] Server side inbox is not updated if Email app is closed immediately after deleting email

RESOLVED DUPLICATE of bug 804904

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 804904
4 years ago
4 years ago

People

(Reporter: Matthew Vaughan, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 affected, b2g-v1.2 affected)

Details

(Whiteboard: burirun2)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 814600 [details]
LogCat for Yahoo email

Description:
When a user deletes their email within the Email app, and then closes it right after, the server side inbox does not always update. 

With Yahoo mail, sometimes the emails deleted from the phone will update the server to include those emails in Yahoo's Trash folder, but will also remain in the Inbox. Alternatively, the emails will sometimes simply remain in the Inbox on the server and the phone will get the deleted emails synced back to the phone's Inbox.

With Gmail, the emails deleted from the phone will not update the server Inbox and therefore will remain there. When the phone synchronizes the Inbox again, the phone will get the emails that were originally deleted from the phone. 

With Outlook, the server appears to update correctly.

Repro Steps:
1) Update Buri to Build ID: 20131008004009
2) Launch the Email app
3) Setup a new Yahoo email account on the phone
4) On a computer, send an email to the Yahoo email account
5) Manually sync the Yahoo Inbox on the phone
6) Delete the new email and then immediately terminate the Email app
7) On a computer, sign into the Yahoo email account
8) Observe email that was deleted on the phone is in the Inbox
9) Open the Email app on the phone
10) Manually sync the Yahoo Inbox on the phone

Actual:
Email that was deleted on the phone is not deleted on the server Inbox and will sync back to the phone Inbox.

Expected:
Email that was deleted on the phone is moved to Trash on the server.

Environmental Variables
Device: Buri
Build ID: 20131008004009
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/decf58f0d596
Gaia: 313599c293f596519604070fa378ffc89e61e98f
Platform Version: 26.0a2


Notes:
Repro frequency: 100%
See attached: logcat_gmail.txt ; logcat_yahoo.txt ; logcat_outlook.txt
(Reporter)

Comment 1

4 years ago
Created attachment 814601 [details]
LogCat for Gmail
(Reporter)

Comment 2

4 years ago
Created attachment 814602 [details]
LogCat for Outlook
(Reporter)

Comment 3

4 years ago
This bug does occur on the 10/07/13 1.1 build, but not as frequently. This may be due to a performance issue where the user cannot terminate the Email app as quickly as they can in 1.2.

Environmental Variables
Build ID: 20131007041201
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c630289d6388
Gaia: e5adcf3c23b6709a51087539bc4cdb67683ca4a0
Platform Version: 18.1
status-b2g18: --- → affected
status-b2g-v1.2: --- → affected
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 804904
You need to log in before you can comment on or make changes to this bug.