can select options within the OPTGROUP (the disabled attribute has ben set)

VERIFIED FIXED in Future

Status

()

VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: madhur, Assigned: rods)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
1. open the testcase provided below
2. tab to the control
3. use the keyboard up-down arrow keys to navigate within the control and make 
selection.

actual:
you will notice that if you use the up-down arrows, u are able to select the 
options that are enclosed within the OPTGROUP - "ground" (which has the disabled 
property set)

whereas, if you mouse-click on these options ("bus", "car") under disabled 
Optgroup ("ground") you are not able to make the selection

expected:
since the optgroup as whole has been set to 'disabled', the user should not be 
able to make a selection of the options within this control - neither by 
mouse-click(which behaves correctly) nor by keyboard selection (this is not 
working as desired).
(Reporter)

Comment 1

17 years ago
Created attachment 43703 [details]
test case
(Reporter)

Comment 2

17 years ago
Note: even the disabled OPTGROUP is not greyed out - as any other disabled 
form-control is supposed to be.

Comment 3

17 years ago
This is fixed in the patch for bug 34297.  Setting dependent.
Depends on: 34297
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 4

17 years ago
Fixed with bug 34297 landing.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

17 years ago
verified fixed on 
win2000 build ID: 2001-11-08-06trunk
macOS 9.1 buildID : 2001-11-08-08trunk
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

17 years ago
The fix for this bug only shows in the trunk builds.

I can still reproduce the bug in 0.9.4 branch build + the 6.2.1 rtm builds --- 
on all platforms.

Please move the patch to the 6.2.1 rtm builds, as well. Reopening bug as a 
reminder to check in the patch in the next release. Thanks!
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 7

17 years ago
This was a part of the massive bug 34297 patch.  If you want to check *that* in
to NS6.2, you're a brave man :)  Please reassess this reopening--if this is
critical to that release, an entirely new patch will have to be spun.

Comment 8

17 years ago
Madhur, the fix for this bug (plus 34297) wasn't made until after the 094 branch
was cut and the fix was only applied to the trunk.  

There was not any intention or nomination of this bug to be applied back to the
094 branch.

I'll cc: marek to see if he needs this for our embedding customer.  If so, we
should just open a new bug to apply this fix.

I'm going to mark this bug fixed and verified again.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 9

17 years ago
mark verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.