RTL support for Top Sites

VERIFIED FIXED

Status

()

Firefox for Android
Theme and Visual Design
P1
normal
VERIFIED FIXED
4 years ago
4 months ago

People

(Reporter: Niv Yahel, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

I'm working towards making the Top Sites component of the Homepage compatible with RTL. I will be making bugs "blocking" this bug as I conquer smaller components of it.
(Reporter)

Updated

4 years ago
Depends on: 924700
(Reporter)

Updated

4 years ago
No longer depends on: 924700
(Reporter)

Updated

4 years ago
Blocks: 924700
(Reporter)

Updated

4 years ago
No longer blocks: 924700
Depends on: 924700
(Reporter)

Updated

4 years ago
Depends on: 924703
(Reporter)

Updated

4 years ago
OS: Mac OS X → Android
(Reporter)

Updated

4 years ago
Blocks: 702845

Updated

4 years ago
Blocks: 928663
(Reporter)

Updated

4 years ago
Depends on: 930613

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1

Updated

9 months ago
QA Contact: ioana.chiorean

Comment 1

6 months ago
Seems to be working OK in latest Nightly builds.
Hi Ioana, would you please help us verify this RTL support on Fennec after Bug 1319302 is already resolved fixed ? 
Could you help us create the complete RTL test cases  and its corresponding wiki test page for tracking ?
Thank you!
Flags: needinfo?(ioana.chiorean)

Comment 3

6 months ago
I'd still like to someone having a tablet to verify this is indeed fixed on tablet phones.
Hi Rachelle, I am providing information behalf of Ioana.
Here is the Test Plan for RTL support on Fennec: https://wiki.mozilla.org/QA/Fennec/Support_RTL.

Tested RTL support for Top Sites on latest Nightly (Arabic) and the results:
Phone:
- LG G4 (Android 5.1) - https://i.imgur.com/WNKt9Pq.png
- Lenovo A536 (Android 4.4.2) - https://i.imgur.com/0o8ZZmK.png 
Tablet:
- Nexus 9 (Android 7.0) - https://i.imgur.com/t6qFFGN.png
- Asus ZenPad 8 (Android 6.0.1) - https://i.imgur.com/ZjynFhL.png

Updated

6 months ago
Hardware: x86 → Unspecified
Version: 27 Branch → unspecified

Updated

6 months ago
Depends on: 1321633

Comment 5

6 months ago
(In reply to ItielMaN from comment #1)
> Seems to be working OK in latest Nightly builds.

I take it back.
On my device (Samsung Galaxy S5 G900F Android 6.0.1):
1. Bookmarked pages have no blue star next to it (but they appear in the history page)
2. As stated by Niv Yahel in bug 924700 comment 1, the text in the grid view does not support BiDi
3. bug 1321633 applies here as well

Comment 6

4 months ago
ItielMaN can you please check again with latest builds?

I am seeing the blue star at bookmarks and the fading issues is fixed.
Flags: needinfo?(ioana.chiorean) → needinfo?(itiel_yn8)

Comment 7

4 months ago
This was implemented and works correctly - further bugs that might arise will be linked here for tracking
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED

Updated

4 months ago
Status: RESOLVED → VERIFIED

Comment 8

4 months ago
(In reply to Ioana Chiorean from comment #6)
> ItielMaN can you please check again with latest builds?
> 
> I am seeing the blue star at bookmarks and the fading issues is fixed.

Yep, the blue star seems to be fixed as well.
Flags: needinfo?(itiel_yn8)
Blocks: 1319302
You need to log in before you can comment on or make changes to this bug.