Cannot show keyboard when running Gaia in Firefox Browser Nightly

RESOLVED DUPLICATE of bug 906096

Status

RESOLVED DUPLICATE of bug 906096
5 years ago
5 years ago

People

(Reporter: rudyl, Assigned: janjongboom)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 814698 [details]
The screenshot for keyboard not shown correctly

It seems Gaia keyboard is broken again in FF Nightly.
Recently, we did not change anything in Gaia keyboard that I think would cause this issue, so this might be a Gecko regression?


Here is the error log when I load Gaia with FF Nightly.
--
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "this.__DOM_IMPL__ is undefined" {file: "resource://gre/components/MozKeyboard.js" line: 395}]' when calling method: [nsIInputMethod::oninputcontextchange]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: http://keyboard.gaiamobile.org:8080/js/keyboard.js :: initKeyboard :: line 486"  data: yes]
************************************************************
JavaScript error: http://keyboard.gaiamobile.org:8080/js/keyboard.js, line 486: NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: '[JavaScript Error: "this.__DOM_IMPL__ is undefined" {file: "resource://gre/components/MozKeyboard.js" line: 395}]' when calling method: [nsIInputMethod::oninputcontextchange]
************************************************************ 

FF Nightly version: 27.0a1 (2013-10-08)
Gaia rev: cbb6174cd51222fbc3d3b1d4e12620666aceca38
(Assignee)

Updated

5 years ago
Assignee: nobody → janjongboom
Think it's because gaia patch for 906096 has been backed out. Will investigate.
Fixed. Please make clean and re-make profile.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906096
You need to log in before you can comment on or make changes to this bug.